summaryrefslogtreecommitdiff
path: root/dev-java/commons-email
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/commons-email
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/commons-email')
-rw-r--r--dev-java/commons-email/Manifest4
-rw-r--r--dev-java/commons-email/commons-email-1.4.ebuild53
-rw-r--r--dev-java/commons-email/files/commons-email-1.4-build.xml261
-rw-r--r--dev-java/commons-email/metadata.xml8
4 files changed, 326 insertions, 0 deletions
diff --git a/dev-java/commons-email/Manifest b/dev-java/commons-email/Manifest
new file mode 100644
index 000000000000..a0e3d4707e60
--- /dev/null
+++ b/dev-java/commons-email/Manifest
@@ -0,0 +1,4 @@
+AUX commons-email-1.4-build.xml 10956 BLAKE2B ed6aca64d4aa19035754ccff5c1acd4a8351d60144b2794c2116e8c0175a3cd1879d25afa97e9ca066d3f525481bd0ecd2ade32c152ec822cd1fe0ced7993cad SHA512 2555322efb15f1f4d26d78bea3638ae20b002c431891ec5ab8a45ef88df23b67f0ac0caf3fbba17e8f32fc2474eb09ae481bed05eb2b612386f31df5b0007cdb
+DIST commons-email-1.4-src.tar.gz 288876 BLAKE2B 17de5c947e68db988b5999ab95f122570a9f52f0557bbdb9a483676576a81d6cfb150058a0ed530bc8dde8732313839e320f4bd7ecfc088b483947dde5760441 SHA512 2a62256e284b9f4f428cf8544e46e81aa521476c41243df1c4f8a9e1bd4bcea3c768346aaab862b8c2a8b271c6012a38164c6d62867d2849a3ee0c2820fe422c
+EBUILD commons-email-1.4.ebuild 1089 BLAKE2B 017b1443086d1eee4e3778a95e8b2bf3ad1f06e5c8146448d57f1ab83917df2631f101f2a20c23d1cdc9e5705939152a7534eaab69f07ceec69c342af7d49799 SHA512 a85d7e3ec14da9425519bf15ba4f4e576fcf9ed0dc5c3482ed9ecde53168ea067b16bf0aef6b06668ff0b6a0a224a20b1943c3a834b73764b870b52676cddb83
+MISC metadata.xml 236 BLAKE2B 5a64c4404c26415501f50132968e687d4f1b852738cb0e1a5aef8cc4de9e4ea623066f46068fce3d80514ff122d85304e3fd12282c4b1513a4084523ef8bef07 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253
diff --git a/dev-java/commons-email/commons-email-1.4.ebuild b/dev-java/commons-email/commons-email-1.4.ebuild
new file mode 100644
index 000000000000..ebcea82ec21e
--- /dev/null
+++ b/dev-java/commons-email/commons-email-1.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+JAVA_PKG_IUSE="source doc test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Commons Email aims to provide an API for sending email."
+HOMEPAGE="http://commons.apache.org/email/"
+SRC_URI="mirror://apache/commons/email/source/${P}-src.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE=""
+
+# Requires a slew of packages we don't ship yet.
+RESTRICT="test"
+
+CDEPEND="dev-java/oracle-javamail:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CDEPEND}
+ test? (
+ dev-java/ant-junit:0
+ )
+ >=virtual/jdk-1.6"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+EANT_GENTOO_CLASSPATH="oracle-javamail"
+EANT_BUILD_TARGET="package"
+
+java_prepare() {
+ cp "${FILESDIR}/${P}-build.xml" build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar "target/${P}.jar" "${PN}.jar"
+ dodoc {NOTICE,README,RELEASE-NOTES}.txt || die
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java
+}
diff --git a/dev-java/commons-email/files/commons-email-1.4-build.xml b/dev-java/commons-email/files/commons-email-1.4-build.xml
new file mode 100644
index 000000000000..9fb5f0e373bf
--- /dev/null
+++ b/dev-java/commons-email/files/commons-email-1.4-build.xml
@@ -0,0 +1,261 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 9/29/15 9:53 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="commons-email-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="commons-email-1.4"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.resourceDir.1" value="."/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.build.testResourceDir.1" value="."/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ </path>
+ <path id="build.test.classpath">
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.outputDir}/META-INF"/>
+ <copy todir="${maven.build.outputDir}/META-INF">
+ <fileset dir="${maven.build.resourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.6"
+ verbose="false"
+ fork="false"
+ source="1.6">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ <mkdir dir="${maven.build.testOutputDir}/META-INF"/>
+ <copy todir="${maven.build.testOutputDir}/META-INF">
+ <fileset dir="${maven.build.testResourceDir.1}">
+ <include name="NOTICE.txt"/>
+ <include name="LICENSE.txt"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="org/apache/commons/mail/mocks/*"/>
+ <exclude name="org/apache/commons/mail/settings/*"/>
+ <exclude name="**/Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="org/apache/commons/mail/mocks/*"/>
+ <exclude name="org/apache/commons/mail/settings/*"/>
+ <exclude name="**/Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present" classpathref="build.test.classpath"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in the test classpath or your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="UTF-8"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ docencoding="UTF-8"
+ source="1.6"
+ linksource="true"
+ breakiterator="false">
+ <link href="http://docs.oracle.com/javase/7/docs/api/"/>
+ <link href="http://docs.oracle.com/javaee/6/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ <attribute name="Main-Class" value="Main"/>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+</project>
diff --git a/dev-java/commons-email/metadata.xml b/dev-java/commons-email/metadata.xml
new file mode 100644
index 000000000000..952a4b9b605c
--- /dev/null
+++ b/dev-java/commons-email/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>