summaryrefslogtreecommitdiff
path: root/dev-java/commons-lang/commons-lang-2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/commons-lang/commons-lang-2.0-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/commons-lang/commons-lang-2.0-r2.ebuild')
-rw-r--r--dev-java/commons-lang/commons-lang-2.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-java/commons-lang/commons-lang-2.0-r2.ebuild b/dev-java/commons-lang/commons-lang-2.0-r2.ebuild
new file mode 100644
index 000000000000..56f3b88e3f97
--- /dev/null
+++ b/dev-java/commons-lang/commons-lang-2.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Jakarta components to manipulate core java classes"
+HOMEPAGE="http://commons.apache.org/lang/"
+SRC_URI="mirror://apache/jakarta/commons/lang/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )"
+RDEPEND=">=virtual/jre-1.4"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}/${P}-src"
+
+java_prepare() {
+ rm -v *.jar || die
+}
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt || die
+ java-pkg_dohtml DEVELOPERS-GUIDE.html PROPOSAL.html STATUS.html
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}