summaryrefslogtreecommitdiff
path: root/dev-java/cssparser/cssparser-0.9.26.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
commitf625b9919a60a30f1bd860f7d1b2eac183ced593 (patch)
tree7543f00925ff7277e31881de0a87801681f6f92f /dev-java/cssparser/cssparser-0.9.26.ebuild
parente3872864be25f7421015bef2732fa57c0c9fb726 (diff)
gentoo resync : 08.08.2018
Diffstat (limited to 'dev-java/cssparser/cssparser-0.9.26.ebuild')
-rw-r--r--dev-java/cssparser/cssparser-0.9.26.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/cssparser/cssparser-0.9.26.ebuild b/dev-java/cssparser/cssparser-0.9.26.ebuild
new file mode 100644
index 000000000000..6b38a3223d5f
--- /dev/null
+++ b/dev-java/cssparser/cssparser-0.9.26.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="API for parsing CSS 2 in Java"
+HOMEPAGE="http://cssparser.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-sources.jar -> ${P}.jar"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/sac:0"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+JAVA_GENTOO_CLASSPATH="sac"