summaryrefslogtreecommitdiff
path: root/dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild')
-rw-r--r--dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild b/dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild
deleted file mode 100644
index f6a9d2f071d3..000000000000
--- a/dev-java/felix-gogo-runtime/felix-gogo-runtime-0.10.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit java-pkg-2 java-ant-2 java-osgi
-
-DESCRIPTION="Felix Gogo Runtime"
-HOMEPAGE="http://felix.apache.org/site/apache-felix-gogo.html"
-LICENSE="Apache-2.0"
-
-MY_PN="org.apache.felix.gogo.runtime"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="mirror://apache/felix/${MY_P}-project.tar.gz"
-SLOT="0"
-KEYWORDS="amd64"
-
-DEPEND=">=virtual/jdk-1.6
- dev-java/osgi-compendium:0
- dev-java/osgi-core-api:0"
-
-RDEPEND=">=virtual/jre-1.6"
-
-S="${WORKDIR}/${MY_P}"
-
-java_prepare() {
- cp "${FILESDIR}"/${P}-build.xml build.xml || die
-
- epatch "${FILESDIR}"/${P}-event-properties-to-map.patch
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-src_compile() {
- EANT_EXTRA_ARGS="-Dgentoo.classpath=$(java-pkg_getjar --build-only osgi-core-api osgi-core-api.jar):$(java-pkg_getjar --build-only osgi-compendium osgi-compendium.jar)"
-
- java-pkg-2_src_compile
-}
-
-src_install() {
- java-osgi_newjar "${S}"/target/${MY_P}.jar ${MY_PN} ${MY_PN} "Export-Package: ${MY_PN}"
-}