summaryrefslogtreecommitdiff
path: root/dev-java/gnu-jaf/gnu-jaf-1.1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-java/gnu-jaf/gnu-jaf-1.1.2-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-java/gnu-jaf/gnu-jaf-1.1.2-r1.ebuild')
-rw-r--r--dev-java/gnu-jaf/gnu-jaf-1.1.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/gnu-jaf/gnu-jaf-1.1.2-r1.ebuild b/dev-java/gnu-jaf/gnu-jaf-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..6c4ef7d1e74d
--- /dev/null
+++ b/dev-java/gnu-jaf/gnu-jaf-1.1.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="GNU implementation of the JavaBeans Activation Framework"
+HOMEPAGE="https://www.gnu.org/software/classpathx/jaf/jaf.html"
+SRC_URI="mirror://gnu/classpathx/activation-${PV}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/activation-${PV}"
+
+EANT_BUILD_TARGET="activation.jar"
+
+src_install() {
+ java-pkg_dojar activation.jar
+ einstalldocs
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc source/*
+}