summaryrefslogtreecommitdiff
path: root/dev-java/gson/gson-2.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/gson/gson-2.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/gson/gson-2.7.ebuild')
-rw-r--r--dev-java/gson/gson-2.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-java/gson/gson-2.7.ebuild b/dev-java/gson/gson-2.7.ebuild
new file mode 100644
index 000000000000..fc8a91b02a0f
--- /dev/null
+++ b/dev-java/gson/gson-2.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_P="${PN}-parent-${PV}"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java library to convert JSON to Java objects and vice-versa"
+HOMEPAGE="https://github.com/google/gson"
+SRC_URI="https://github.com/google/${PN}/archive/${MY_P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="2.7"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.7"
+RDEPEND=">=virtual/jre-1.7"
+
+S="${WORKDIR}/${PN}-${MY_P}"
+JAVA_SRC_DIR="${PN}/src/main/java"