summaryrefslogtreecommitdiff
path: root/dev-java/jacl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jacl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jacl')
-rw-r--r--dev-java/jacl/Manifest3
-rw-r--r--dev-java/jacl/jacl-1.4.1-r1.ebuild52
-rw-r--r--dev-java/jacl/metadata.xml41
3 files changed, 96 insertions, 0 deletions
diff --git a/dev-java/jacl/Manifest b/dev-java/jacl/Manifest
new file mode 100644
index 000000000000..c0830190e9d6
--- /dev/null
+++ b/dev-java/jacl/Manifest
@@ -0,0 +1,3 @@
+DIST jacl-1.4.1.tar.gz 1921630 BLAKE2B 1b5693aa79fc50b5ff7a1ef86608b640d0bf391ced72dbe5d30f30fb46b26174535aac9d0ec32e1528f16af9e54def344d2fe38602700f921d612761f706fcce SHA512 e4b906efbd3ef4ab9338e8bf2f50c3b820e25b9fbe61f194e90cc0fa128f68d64eb459f7b05171d4b86b4c9635ef483906a02952bdedcee89ccb92256b789247
+EBUILD jacl-1.4.1-r1.ebuild 975 BLAKE2B 6a0183b04ed9e4d0ea797d19e53774653fdb3bac4e9e2039fd8b9f0eee3814c9ae643411e6c00dfd41a4a5cb14cbb98f480a7fb18700aca17147007af3572b02 SHA512 7114f0f2d99e2a06b58eb5f0b9443e69baaeed5fb81ec7ac1c42a3915db12ba773903536677cdae93aa8a956b87911b8d08291ab9fb4087bcc651d005e0aa4eb
+MISC metadata.xml 2116 BLAKE2B 5dd3d0eaa2e83ff6b387c77b1b4a156502925bf37334b7b7ffabb7ed7ba6368cdada2f61881812225215233acd2df7cc9a611b377188e1f67c2960f60c1e616f SHA512 221bd082cf7a036c0417d003a216bd919f8d6391211da62abaf57c560f192bbe27dba23c260a4d731e09e46dd0e30b4a185a45ccf7375908b947667bf5df7966
diff --git a/dev-java/jacl/jacl-1.4.1-r1.ebuild b/dev-java/jacl/jacl-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..2a090c5d697a
--- /dev/null
+++ b/dev-java/jacl/jacl-1.4.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${P//-}"
+
+DESCRIPTION="Jacl is an implementation of Tcl written in Java"
+HOMEPAGE="http://tcljava.sourceforge.net"
+SRC_URI="mirror://sourceforge/tcljava/${MY_P}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86"
+IUSE="doc"
+
+CDEPEND=">=dev-lang/tcl-8.4.5:*"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+DEPEND="
+ ${CRDEPEND}
+ >=virtual/jdk-1.6"
+
+S="${WORKDIR}/${MY_P}"
+
+JAVA_SRC_DIR="src"
+
+java_prepare() {
+ java-pkg_clean
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ rm -rf src/{Test.java,empty,tests,janino} || die
+ java-pkg-simple_src_compile
+ mv src/jacl/tcl src/ || die
+ java-pkg_addres "${PN}.jar" src/ -name "*.tcl"
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher jaclsh --main tcl.lang.Shell
+ dodoc README ChangeLog known_issues.txt || die
+}
diff --git a/dev-java/jacl/metadata.xml b/dev-java/jacl/metadata.xml
new file mode 100644
index 000000000000..3b8f63c2a9f6
--- /dev/null
+++ b/dev-java/jacl/metadata.xml
@@ -0,0 +1,41 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <longdescription>
+The Tcl/Java project's goal is to make integrating the Java platform and the
+Tcl scripting language as easy as possible. The project actually consists of
+two distinct packages, called Tcl Blend and Jacl. It is important to
+understand what each package provides and in what situations one might choose
+to use Jacl or Tcl Blend.
+
+Tcl Blend is a Tcl extension that makes use of JNI to facilitate communication
+between a Java interpreter and a Tcl interpreter. Tcl Blend is typically used
+to load a Java interpreter into an existing Tcl process, so that functionality
+implemented in Java can be accessed via Tcl. One can also load Tcl Blend and
+Tcl into a Java process, which is a great way to add scripting functionality
+to an existing Java application. Because Tcl Blend is a normal Tcl extension,
+one can use it with other popular Tcl extensions like Tk, Expect, and Itcl.
+
+Jacl is a self-contained implementation of a Tcl interpreter, written entirely
+in Java. Jacl also includes features that facilitate communication between a
+Java interpreter and a Tcl interpreter. Jacl is typically used to incorporate
+scripting functionality into an existing Java application. For users who want
+to avoid adding any native code to their Java applications, Jacl is the ideal
+solution.
+
+Tcl Blend and Jacl define both a Tcl API and a Java API that make it easy to
+call Java code from Tcl or call Tcl code from Java. For example, one could
+allocate a Java object in a Tcl script and interactively invoke Java methods
+on the object. It is also easy to use the supplied API to evaluate a Tcl
+procedure from a Java method or implement Tcl procudures in Java. The flexible
+API and wealth of implementation options provided by the Tcl/Java project make
+integrating Tcl and Java easy.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">tcljava</remote-id>
+ </upstream>
+</pkgmetadata>