summaryrefslogtreecommitdiff
path: root/dev-java/janino
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-java/janino
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-java/janino')
-rw-r--r--dev-java/janino/Manifest4
-rw-r--r--dev-java/janino/janino-3.1.7.ebuild (renamed from dev-java/janino/janino-3.1.6.ebuild)22
2 files changed, 15 insertions, 11 deletions
diff --git a/dev-java/janino/Manifest b/dev-java/janino/Manifest
index 1f3cc5e6cdb9..66375ed5fae1 100644
--- a/dev-java/janino/Manifest
+++ b/dev-java/janino/Manifest
@@ -1,3 +1,3 @@
-DIST janino-3.1.6.tar.gz 1730264 BLAKE2B a4e15b7b9a9d17b8762f5964171a01da3ce6f1045b8830c9a6e9a0d35c5096376fd667103360791f6848c762177f48f858e4e6233205fb6ff8258e6582211b89 SHA512 6e729733f74e0cc24db56c4030de8751c131c94b3abf0519288cc7539b5dda45de8c33e8dd37d8e70565ad0c3a3122cac7c73d77bc5f92a16db0b0f7ea7436d3
-EBUILD janino-3.1.6.ebuild 2450 BLAKE2B bb333aa06465cde9ad61f34642a7753f48603cb7328fdb9bf0ab888bdcdc24f6fb642621e65a6a46fb9d4db08cde39fe6b1542c754b14d5f73f490e8575a1217 SHA512 2bdeb13ed634e0af780c9e9ce236e88996ffa184477fd3813383e771b0243223950fb0fe4c25200c56086eb1243a552ba6913c1d3ec7eccdada2413c6fc688dc
+DIST janino-3.1.7.tar.gz 1747439 BLAKE2B 6e42a9d5cc079c2cf17b76c1d76420ff3fa0027b54736f23e0aa2c5062f4dad19c1ac7efa678fa06cee369a01125a64a4ee32e4120e60ecd8a56d47aa4f69503 SHA512 541925fc10f5fbefde45e60cec1925e3d6f5b7244a6b9de251b5483224bee05c16182e2bf137a00349cbdb6c209ce18b2203ca066e5a7a1f146efa255f5f7799
+EBUILD janino-3.1.7.ebuild 2531 BLAKE2B ae499ba288a32289cc580df385fb0ad4c5c8a91a3cc6438dacf7c27f1fbbf9ed777dbbbfd75e7e092d0f453a396cdd45803b8cc5087b039b265a48c8244cfec1 SHA512 f8a736543205c5f471196d02cd01af3b5746118f091ee12e024ce2b2d8c4438d6bcfab5476c1c3a75c37a89e95811e9a39d947ad629f3eab3402c1dd8614ed4f
MISC metadata.xml 402 BLAKE2B 24ce6bf4574089a37f3f65f463269ffaa05cc5491b630b69ce205d62967d9dda038caa1af286974c908921c57819e59c4f63a1377c3c6d4dc5ab87fbc20286da SHA512 c26dddfc7e65fcfe8cd2d359acecc410592cbe1b73453110b3c27b360676d3ecdd247e05c936bef1125d19d97e78ccaeaff9707f52be882e5dd14b9b1b04df56
diff --git a/dev-java/janino/janino-3.1.6.ebuild b/dev-java/janino/janino-3.1.7.ebuild
index 1da22362d3d2..46f3e8c96ec4 100644
--- a/dev-java/janino/janino-3.1.6.ebuild
+++ b/dev-java/janino/janino-3.1.7.ebuild
@@ -2,32 +2,36 @@
# Distributed under the terms of the GNU General Public License v2
# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom janino/pom.xml --download-uri https://codeload.github.com/janino-compiler/janino/tar.gz/v3.1.6 --slot 0 --keywords "~amd64" --ebuild JANjanino-3.1.6.ebuild
+# java-ebuilder --generate-ebuild --workdir . --pom janino/pom.xml --download-uri https://github.com/janino-compiler/janino/archive/refs/tags/v3.1.7.tar.gz --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild janino-3.1.7.ebuild
EAPI=8
JAVA_PKG_IUSE="doc source test"
-MAVEN_ID="org.codehaus.janino:janino:3.1.6"
+MAVEN_ID="org.codehaus.janino:janino:3.1.7"
JAVA_TESTING_FRAMEWORKS="junit-4"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="An embedded compiler for run-time compilation purposes"
HOMEPAGE="https://janino-compiler.github.io/janino/"
-SRC_URI="https://codeload.github.com/janino-compiler/janino/tar.gz/v${PV} -> ${P}.tar.gz"
+SRC_URI="https://github.com/janino-compiler/janino/archive/v3.1.7.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
# Common dependencies
-# POM: janino/pom.xml
-# org.codehaus.janino:commons-compiler:3.1.6 -> !!!groupId-not-found!!!
+# POM: ${PN}/pom.xml
+# org.codehaus.janino:commons-compiler:3.1.7 -> !!!artifactId-not-found!!!
+
+CDEPEND="
+ !!!artifactId-not-found!!!
+"
# Compile dependencies
-# POM: janino/pom.xml
-# org.apache.ant:ant:1.10.9 -> !!!groupId-not-found!!!
-# POM: janino/pom.xml
+# POM: ${PN}/pom.xml
+# org.apache.ant:ant:1.10.11 -> !!!suitable-mavenVersion-not-found!!!
+# POM: ${PN}/pom.xml
# test? junit:junit:4.13.1 -> >=dev-java/junit-4.13.2:4
DEPEND="