summaryrefslogtreecommitdiff
path: root/dev-java/jboss-marshalling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jboss-marshalling
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jboss-marshalling')
-rw-r--r--dev-java/jboss-marshalling/Manifest4
-rw-r--r--dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r1.ebuild26
-rw-r--r--dev-java/jboss-marshalling/jboss-marshalling-1.3.0.ebuild27
-rw-r--r--dev-java/jboss-marshalling/metadata.xml8
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-java/jboss-marshalling/Manifest b/dev-java/jboss-marshalling/Manifest
new file mode 100644
index 000000000000..dd0b1bb692ba
--- /dev/null
+++ b/dev-java/jboss-marshalling/Manifest
@@ -0,0 +1,4 @@
+DIST jboss-marshalling-1.3.0.CR9-sources.jar 174155 BLAKE2B 1c1a25910eb9d9d40f4f3cbb8bb6d7d59272e4806a39b602e1e336269eb3fa95d83a89b46967919d2e02b5647f43e42495f36777d82e706f1853b717f3e0e44e SHA512 d7a1ae24ec50acf20f8150cf6e741a846e9a5837f9d8e4c06d8429793f69b95a7c03449ba5a6debb00bd22b596b6f801e25e0f38ccce7ac25cafd601e2ef7058
+EBUILD jboss-marshalling-1.3.0-r1.ebuild 588 BLAKE2B 8fac0c5ad50ea655f1f11c8620cfd28dc8254926e9ad4b67662cf9dc443166002432105597f222e6ac41dd1c17f4d7f2d34e9cacf53cb54e66777bc36be6088a SHA512 7f517568ba25e4661a5c58f0eb64b9438d71e750aca3ef2c265a61ae40bbc07edc0816e55f08c3f1a66eb54d7bb0f8166de1f4dc93e89b326783ebac35e10311
+EBUILD jboss-marshalling-1.3.0.ebuild 606 BLAKE2B c7da32dfa5bae1633f678ee6f0ddc1bca320ef225228b37f58a8963caf94de293ef42eba656fe20dacd332e82f737a74acef260038af35272e0c3cae939c4492 SHA512 12589e07068598074c588c73e944b6f985b74361b2fc5d737c427c951d6253469a0f2616353e0e50055ede05dc578bd7146bf985864a06ddad9ba67210b60758
+MISC metadata.xml 232 BLAKE2B 513679b02247d8e4cb4c874abd785119d9ca62ad24c44969d52a42c3765d0ebf689024512a2c4c48e69688a4ce02a74ae05708b050a720bc73d8d2bf2ceff58d SHA512 00beaf2c81112ff757c4395f4ea47e85f2d48e369e241f10ddf200090dd6513d52ae2b1aef6d28b7417f1cf34608a7258a167eb307d5670323a2190f3710f893
diff --git a/dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r1.ebuild b/dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..8aec3b3085ba
--- /dev/null
+++ b/dev-java/jboss-marshalling/jboss-marshalling-1.3.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Compatible alternative to the JDK serialization API"
+HOMEPAGE="http://jbossmarshalling.jboss.org/"
+SRC_URI="http://download.jboss.org/jbossmarshalling/${P}.CR9-sources.jar"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+CDEPEND="dev-java/jboss-modules:0"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.7"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.7
+ app-arch/unzip"
+
+JAVA_GENTOO_CLASSPATH="jboss-modules"
diff --git a/dev-java/jboss-marshalling/jboss-marshalling-1.3.0.ebuild b/dev-java/jboss-marshalling/jboss-marshalling-1.3.0.ebuild
new file mode 100644
index 000000000000..8c31574bdf5e
--- /dev/null
+++ b/dev-java/jboss-marshalling/jboss-marshalling-1.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-pkg-simple
+
+HOMEPAGE="http://jbossmarshalling.jboss.org/"
+SRC_URI="http://download.jboss.org/jbossmarshalling/jboss-marshalling-${PV}.CR9-sources.jar"
+DESCRIPTION="Compatible alternative to the JDK serialization API"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+
+CDEPEND="dev-java/jboss-modules:0"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.5
+ ${CDEPEND}"
+
+JAVA_SRC_DIR="org"
+JAVA_GENTOO_CLASSPATH="jboss-modules"
diff --git a/dev-java/jboss-marshalling/metadata.xml b/dev-java/jboss-marshalling/metadata.xml
new file mode 100644
index 000000000000..2444066aa02b
--- /dev/null
+++ b/dev-java/jboss-marshalling/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+</maintainer>
+</pkgmetadata>