summaryrefslogtreecommitdiff
path: root/dev-java/jclasslib/jclasslib-3.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-java/jclasslib/jclasslib-3.1-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-java/jclasslib/jclasslib-3.1-r1.ebuild')
-rw-r--r--dev-java/jclasslib/jclasslib-3.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/jclasslib/jclasslib-3.1-r1.ebuild b/dev-java/jclasslib/jclasslib-3.1-r1.ebuild
new file mode 100644
index 000000000000..5234a552cfb2
--- /dev/null
+++ b/dev-java/jclasslib/jclasslib-3.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java bytecode viewer"
+HOMEPAGE="https://github.com/ingokegel/jclasslib"
+SRC_URI="https://github.com/ingokegel/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+src_install() {
+ java-pkg_dojar "build/${PN}.jar"
+
+ java-pkg_dolauncher "${PN}" \
+ --main org.gjt.jclasslib.browser.BrowserApplication
+
+ use doc && java-pkg_dohtml -r doc/*
+ use source && java-pkg_dosrc src/*
+}
+
+pkg_postinst() {
+ elog "jclasslib uses Firefox by default."
+ elog "Set the BROWSER environment at your discretion."
+}