summaryrefslogtreecommitdiff
path: root/dev-java/jdepend/jdepend-2.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-java/jdepend/jdepend-2.10.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-java/jdepend/jdepend-2.10.ebuild')
-rw-r--r--dev-java/jdepend/jdepend-2.10.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-java/jdepend/jdepend-2.10.ebuild b/dev-java/jdepend/jdepend-2.10.ebuild
new file mode 100644
index 000000000000..1a92cd4f53c8
--- /dev/null
+++ b/dev-java/jdepend/jdepend-2.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Traverses Java class file directories and generates design quality metrics"
+HOMEPAGE="https://github.com/clarkware/jdepend"
+SRC_URI="https://github.com/clarkware/jdepend/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+src_install() {
+ java-pkg_newjar dist/jdepend-${PV}.jar
+ dodoc README.md LICENSE.md ClassFileFormat-Java5.pdf
+ docinto html
+ dodoc -r docs/*
+ use doc && java-pkg_dojavadoc build/docs/api
+ use source && java-pkg_dosrc src/*
+}