summaryrefslogtreecommitdiff
path: root/dev-java/jempbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jempbox
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jempbox')
-rw-r--r--dev-java/jempbox/Manifest6
-rw-r--r--dev-java/jempbox/files/jempbox-1.7.1_maven-build.xml247
-rw-r--r--dev-java/jempbox/jempbox-1.7.1.ebuild45
-rw-r--r--dev-java/jempbox/jempbox-1.8.11.ebuild45
-rw-r--r--dev-java/jempbox/metadata.xml11
5 files changed, 354 insertions, 0 deletions
diff --git a/dev-java/jempbox/Manifest b/dev-java/jempbox/Manifest
new file mode 100644
index 000000000000..1973b7ac7082
--- /dev/null
+++ b/dev-java/jempbox/Manifest
@@ -0,0 +1,6 @@
+AUX jempbox-1.7.1_maven-build.xml 10502 BLAKE2B 041be81aaf3b81969ad26926a3f2eac7b4655c17b3ba925b6ec2b16ddf49bcf7d87fc32655e3e357f274acc16a052afbc8010c6e0fc06f8e51770d68478e2efd SHA512 230436b03ddd8146f6aca41b26f54c0beba208eed9836aaf12e1326de75f226572e473e28c3d313c49a53266d3a827ee62097a49849d1782c546fe9e8bc1d269
+DIST pdfbox-1.7.1-src.zip 9167805 BLAKE2B f9e02d1540eaf7e4bb748906e56887494d81eecc88685fa9d758cb50712a530528573f4a7e5f816b4ff57d664a416b35444517d840c9b37239ec1e2b5a62b5a1 SHA512 8b2af3d8f431626c106e4f6e9e1d59d14abcd58cfdc9553f20c5057eef9f9cfbd0287e14e58e4d34472ad81198eb3f4d0a2fd6e88bd1fa5cbcf01e4befbf77d0
+DIST pdfbox-1.8.11-src.zip 11026359 BLAKE2B b3eb1add38e9bd0e5a1fcb116263fdbc372d6adb77132aeb0647a6c5d2c2b735345220f0a5c22caa97d04f78ad6517df388327aaa625677bd8c99d2051329a9c SHA512 05c8e5075379ed5ebb09555b39434dd936fce9dd24445871d24ea7f0f6afa49e74242bf0c9eba2d1a847b505143789b687dd039ca51ce76851132f2f18d434d1
+EBUILD jempbox-1.7.1.ebuild 874 BLAKE2B 28f129024f2e1d52d3120857ae09c24857ab5743a047ff454a575ae2a7c9fb4a043735efa0ece97aaa35e30d46e08dad0d8cbaa3a5ba46dbfd2907f40d0fa534 SHA512 543459515df66a6315938c6a5fb7a9c4dfdbd7ab56de552bb84da1bb6f6ec5aa59dee390e3afb479b477cb79d2e011b9fe1787b16329fd7a283d1f3463d29857
+EBUILD jempbox-1.8.11.ebuild 1017 BLAKE2B 3b08bb9827e2ff319f3885c24defb4456b13c391bbcb97787d7a5f45fed2edb494ec8b1ddf41fbba9f4a47115386d3dd82ea2231cf2915951d6a086ac74e8499 SHA512 7d31ea467b558f892ed798df1dd87bcd4d0f1a8869a3a8655162036bcafc8641c7f797edabffdf3be0d2382e6a96bac8a0d67f7e09dcfacb95f9a4a239081754
+MISC metadata.xml 314 BLAKE2B 4b4abd03c1f6ec6ebdacfd3f11f8365a9a867f9a4ad809998242c822dee13b75e35dcb44603c51f4b9f57828f71e0d8b09bfef83c3a9ad01111c2bd9410a1695 SHA512 3b771fec64eb63ed8b1de377745aa069c22e8cae003bf4155729ab8cb5c6a1ed5ca70cb977de152bfc926c2c4f6e94db6efc6498091736e0aa5304675b5019e7
diff --git a/dev-java/jempbox/files/jempbox-1.7.1_maven-build.xml b/dev-java/jempbox/files/jempbox-1.7.1_maven-build.xml
new file mode 100644
index 000000000000..453f9f69f665
--- /dev/null
+++ b/dev-java/jempbox/files/jempbox-1.7.1_maven-build.xml
@@ -0,0 +1,247 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 8/2/12 4:32 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jempbox-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jempbox-1.7.1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.5"
+ linksource="false"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/1.5.0/docs/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.8.1"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.8.1/junit-4.8.1.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.8.1/junit-4.8.1.jar"
+ dest="${maven.repo.local}/junit/junit/4.8.1/junit-4.8.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/jempbox/jempbox-1.7.1.ebuild b/dev-java/jempbox/jempbox-1.7.1.ebuild
new file mode 100644
index 000000000000..d5f8087253ab
--- /dev/null
+++ b/dev-java/jempbox/jempbox-1.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN=pdfbox
+
+DESCRIPTION="An open source Java library for parsing font files"
+HOMEPAGE="http://pdfbox.apache.org/"
+SRC_URI="mirror://apache/${MY_PN}/${PV}/${MY_PN}-${PV}-src.zip"
+
+LICENSE="BSD"
+SLOT="1.7"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.5"
+DEPEND="
+ >=virtual/jdk-1.5
+ app-arch/unzip
+ test? ( dev-java/ant-junit:0 )"
+
+S="${WORKDIR}/${MY_PN}-${PV}/${PN}"
+
+java_prepare() {
+ cp -v "${FILESDIR}"/${P}_maven-build.xml build.xml || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/org
+}
diff --git a/dev-java/jempbox/jempbox-1.8.11.ebuild b/dev-java/jempbox/jempbox-1.8.11.ebuild
new file mode 100644
index 000000000000..7653bdb73e99
--- /dev/null
+++ b/dev-java/jempbox/jempbox-1.8.11.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PN="pdfbox"
+MY_P="${MY_PN}-${PV}"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="An open source Java library for working with XMP metadata"
+HOMEPAGE="http://pdfbox.apache.org/"
+SRC_URI="mirror://apache/${MY_PN}/${PV}/${MY_P}-src.zip"
+LICENSE="Apache-2.0"
+SLOT="1.8"
+KEYWORDS="amd64 ~arm64 ppc64 x86"
+IUSE="test"
+
+RDEPEND=">=virtual/jre-1.6"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ test? ( dev-java/junit:4 )"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+JAVA_SRC_DIR="src/main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc README.txt
+}
+
+src_test() {
+ local DIR=src/test/java
+ local CP="${DIR}:${PN}.jar:$(java-pkg_getjars junit-4)"
+ local TESTS=$(find ${DIR} -name "*Test.java")
+ TESTS="${TESTS//src\/test\/java\/}"
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d ${DIR} $(find ${DIR} -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}
diff --git a/dev-java/jempbox/metadata.xml b/dev-java/jempbox/metadata.xml
new file mode 100644
index 000000000000..fac651d95a59
--- /dev/null
+++ b/dev-java/jempbox/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">apache/pdfbox</remote-id>
+ </upstream>
+</pkgmetadata>