summaryrefslogtreecommitdiff
path: root/dev-java/jnr-enxio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/jnr-enxio
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/jnr-enxio')
-rw-r--r--dev-java/jnr-enxio/Manifest4
-rw-r--r--dev-java/jnr-enxio/files/jnr-enxio-0.7-build.xml320
-rw-r--r--dev-java/jnr-enxio/jnr-enxio-0.7-r1.ebuild40
-rw-r--r--dev-java/jnr-enxio/metadata.xml11
4 files changed, 375 insertions, 0 deletions
diff --git a/dev-java/jnr-enxio/Manifest b/dev-java/jnr-enxio/Manifest
new file mode 100644
index 000000000000..1ce1e469b847
--- /dev/null
+++ b/dev-java/jnr-enxio/Manifest
@@ -0,0 +1,4 @@
+AUX jnr-enxio-0.7-build.xml 17106 BLAKE2B b008c295c93839e2bd7086199b4b81c96adcda8ad26e33ece7b0a061b53041e6f481bc73db290d1d9fb15f7bed5a1a3649b79ad20cbcdef299ca6544bc1c2c4a SHA512 e655b5c8900ef050f45fc2a59dbfea520061fad94380d2e43757ed35f676a59f0816d006b4c6c3100cb063c29b44eb6e168edee65027a4a86f9c523ba018ba5e
+DIST jnr-enxio-0.7.tar.gz 10520 BLAKE2B 762c36ad59473d6be4f2c2b8c62ce489fe46ce30afe9b32101aa41ab703c50247cfa0908499f8c2fa79c2ac8c33972abe203984c5cbbe5111416e4684e4c79ed SHA512 ed8c13ae4de2334aa9ddd9a13534e0c49fb1bde48e3bd5085a62c96f2b9fe6970b4ba08fe6b27901c5e6db1b360511265ac276ca56f89fddf5e18db9726bd834
+EBUILD jnr-enxio-0.7-r1.ebuild 941 BLAKE2B 5e3cc61f215fa1432d6d2a01ba4099d54883fdda044e50f5323e75546b7ff602ac741913532c34efe1c0323639b6ee0c3be9c43de58e340d64a5e47777d3b12b SHA512 e3457d222de26e86948170130453b6470c5f7e63d7e01cf5f42c39389c775bb6322523e93f3d589d99ab8a31b8a39fa0a25d73e1938709207df742c16423c12f
+MISC metadata.xml 324 BLAKE2B 9ce9c50c39995314b7a5efe205cb2ef789c6745ac1033792b3fcd2935a0329fd788321481e92a7d468483c73cd87416f2476502097c61854c1dfd97fedde1882 SHA512 6f93b386f5899bf9771f983da31cccd57811bbb3b5691c71698f5a09915e448ad7ba4258da0cf1781d589fbf40611340034048b327b0242bdfcd06fcaa4c1578
diff --git a/dev-java/jnr-enxio/files/jnr-enxio-0.7-build.xml b/dev-java/jnr-enxio/files/jnr-enxio-0.7-build.xml
new file mode 100644
index 000000000000..efdb518451e1
--- /dev/null
+++ b/dev-java/jnr-enxio/files/jnr-enxio-0.7-build.xml
@@ -0,0 +1,320 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 6/6/13 12:27 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jnr-enxio-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jnr-enxio-0.7"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.1"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases"/>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.11"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/junit/junit/4.11/junit-4.11.jar"
+ dest="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.11/junit-4.11.jar"
+ dest="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jffi/1.2.7"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jffi/1.2.7"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-commons/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-tree/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-util/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/jnr-enxio/jnr-enxio-0.7-r1.ebuild b/dev-java/jnr-enxio/jnr-enxio-0.7-r1.ebuild
new file mode 100644
index 000000000000..a5257b885a5e
--- /dev/null
+++ b/dev-java/jnr-enxio/jnr-enxio-0.7-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java Native Runtime Enhanced X-platform I/O"
+SRC_URI="https://github.com/jnr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/jnr/jnr-enxio"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+LICENSE="Apache-2.0"
+
+CDEPEND="dev-java/jnr-constants:0
+ dev-java/jnr-ffi:2"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.7"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.7"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="jnr-constants,jnr-ffi-2"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use source && java-pkg_dosrc src/main/java/jnr
+ use examples && java-pkg_doexamples src/main/java/jnr/enxio/example
+ use doc && java-pkg_dojavadoc target/site/apidocs
+}
diff --git a/dev-java/jnr-enxio/metadata.xml b/dev-java/jnr-enxio/metadata.xml
new file mode 100644
index 000000000000..8dadb2bd8904
--- /dev/null
+++ b/dev-java/jnr-enxio/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jnr/jnr-enxio</remote-id>
+ </upstream>
+</pkgmetadata>