summaryrefslogtreecommitdiff
path: root/dev-java/joni/joni-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/joni/joni-2.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/joni/joni-2.1.0.ebuild')
-rw-r--r--dev-java/joni/joni-2.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-java/joni/joni-2.1.0.ebuild b/dev-java/joni/joni-2.1.0.ebuild
new file mode 100644
index 000000000000..3b88d67b34f0
--- /dev/null
+++ b/dev-java/joni/joni-2.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java port of the Oniguruma regular expression engine"
+HOMEPAGE="https://github.com/codehaus"
+SRC_URI="https://github.com/jruby/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="amd64 ~ppc64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+CDEPEND="dev-java/asm:3
+ dev-java/jcodings:1"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}-${PN}-${PV}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_BUILD_TARGET="build"
+EANT_GENTOO_CLASSPATH="asm-3 jcodings-1"
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use source && java-pkg_dosrc src/*
+}