summaryrefslogtreecommitdiff
path: root/dev-java/lzma/lzma-22.01.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-10 15:28:02 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-10 15:28:02 +0000
commit0d0e3e0adedd9f237ceea9e95cbd0ed29a4576d4 (patch)
treef4f226a7d18e1d67a2f44d24f0485ef3bd630698 /dev-java/lzma/lzma-22.01.ebuild
parente80777b54c5b430ca044e16878f59a2020423d48 (diff)
gentoo auto-resync : 10:11:2022 - 15:28:02
Diffstat (limited to 'dev-java/lzma/lzma-22.01.ebuild')
-rw-r--r--dev-java/lzma/lzma-22.01.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/lzma/lzma-22.01.ebuild b/dev-java/lzma/lzma-22.01.ebuild
new file mode 100644
index 000000000000..fcb02d0d2be1
--- /dev/null
+++ b/dev-java/lzma/lzma-22.01.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple unpacker
+
+DESCRIPTION="Java code for LZMA compression and decompression"
+HOMEPAGE="https://7-zip.org/"
+SRC_URI="https://7-zip.org/a/lzma${PV/./}.7z -> ${P}.7z"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND=">=virtual/jdk-1.8:*"
+BDEPEND="$(unpacker_src_uri_depends)"
+
+S="${WORKDIR}/Java"
+
+JAVA_SRC_DIR="SevenZip"