summaryrefslogtreecommitdiff
path: root/dev-java/lzmajio/lzmajio-0.95-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-java/lzmajio/lzmajio-0.95-r3.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-java/lzmajio/lzmajio-0.95-r3.ebuild')
-rw-r--r--dev-java/lzmajio/lzmajio-0.95-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/lzmajio/lzmajio-0.95-r3.ebuild b/dev-java/lzmajio/lzmajio-0.95-r3.ebuild
new file mode 100644
index 000000000000..e4b47cccb1e9
--- /dev/null
+++ b/dev-java/lzmajio/lzmajio-0.95-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="LzmaInputStream/LzmaOutputStream interacting with underlying LZMA en-/decoders"
+HOMEPAGE="https://contrapunctus.net/league/haques/lzmajio/
+ https://github.com/league/lzmajio"
+SRC_URI="https://github.com/league/${P}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/lzma:0"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.8:*"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="lzma"
+JAVA_SRC_DIR="net"