summaryrefslogtreecommitdiff
path: root/dev-java/mill-bin/mill-bin-0.10.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-25 14:49:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-25 14:49:58 +0100
commitef89e12d3986ab87064b84e073b2a4a11f32c91c (patch)
tree2e4bbfc20faa4927576eed7c8002b5e121f10047 /dev-java/mill-bin/mill-bin-0.10.7.ebuild
parentfae5c40540ab2ebf93e2291bfec510022df02bdc (diff)
gentoo auto-resync : 25:08:2022 - 14:49:58
Diffstat (limited to 'dev-java/mill-bin/mill-bin-0.10.7.ebuild')
-rw-r--r--dev-java/mill-bin/mill-bin-0.10.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/mill-bin/mill-bin-0.10.7.ebuild b/dev-java/mill-bin/mill-bin-0.10.7.ebuild
new file mode 100644
index 000000000000..e8485c57dfd6
--- /dev/null
+++ b/dev-java/mill-bin/mill-bin-0.10.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN%-bin}
+
+DESCRIPTION="A Java/Scala build tool"
+HOMEPAGE="https://com-lihaoyi.github.io/mill/"
+SRC_URI="https://github.com/com-lihaoyi/${MY_PN}/releases/download/${PV}/${PV}-assembly -> ${P}"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ newbin "${DISTDIR}"/${P} ${MY_PN}
+}