summaryrefslogtreecommitdiff
path: root/dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild')
-rw-r--r--dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild b/dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild
new file mode 100644
index 000000000000..29c598b6ed44
--- /dev/null
+++ b/dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Service Platform Compendium API (Companion Code)"
+HOMEPAGE="http://wiki.osgi.org/wiki/Release_4.3"
+SRC_URI="https://osgi.org/download/r4v43/osgi.cmpn-${PV}.jar"
+
+LICENSE="Apache-2.0 OSGi-Specification-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+CDEPEND="dev-java/glassfish-persistence:0
+ dev-java/osgi-core-api:0
+ dev-java/osgi-foundation:0
+ dev-java/tomcat-servlet-api:3.0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+JAVA_GENTOO_CLASSPATH="
+ osgi-core-api
+ osgi-foundation
+ glassfish-persistence
+ tomcat-servlet-api-3.0
+"
+
+java_prepare() {
+ rm -r org || die
+}