summaryrefslogtreecommitdiff
path: root/dev-java/osgi-foundation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/osgi-foundation
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/osgi-foundation')
-rw-r--r--dev-java/osgi-foundation/Manifest4
-rw-r--r--dev-java/osgi-foundation/files/osgi-foundation-1.2.0-build.xml218
-rw-r--r--dev-java/osgi-foundation/metadata.xml8
-rw-r--r--dev-java/osgi-foundation/osgi-foundation-1.2.0-r1.ebuild27
4 files changed, 0 insertions, 257 deletions
diff --git a/dev-java/osgi-foundation/Manifest b/dev-java/osgi-foundation/Manifest
deleted file mode 100644
index 9f91bdc42101..000000000000
--- a/dev-java/osgi-foundation/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX osgi-foundation-1.2.0-build.xml 9886 BLAKE2B aacff8e000b02c742ee7e5d03d2c057b6baf56bce9cc1b9cd0031c39550e9ef07bcf85a7d89dd265cc523d638063e425b1553f146b5ce6af107440b1e0d61d43 SHA512 5f106bd612a65033e35beb4fb635d07199e10b69e692db5949424ecf7a8baf2bd6af0f35898bd465334356333d82d5c4941ef6ce7ce16c3939f425f4e58c6fcc
-DIST osgi-foundation-1.2.0.tar.xz 45176 BLAKE2B 4b5432dfaad9134f402b5f448a8d7ba5f626a7b160bbc953914352a28f745725da851b6c5f2122f820b52f2fd8ad463c2df5c8ae3e2b46ef8bb9d56d89d90f1b SHA512 6523dd6b4cd8205aa3359fae4640ff6b17a1944aec6bf23acf0d6e4eb33839a9b9049e8df0c55a4f35013b40b1df2391a53ed68df682a317c35dca504e9b996b
-EBUILD osgi-foundation-1.2.0-r1.ebuild 634 BLAKE2B 58f8045c4130ae1045c157dcc91ee1455c6f0ef55ad381e8b8da66a6a185e7b21ac3f9eb46990e1fbb755c8497f044f961bde92aa73ca4da6ce8ec6b697d4029 SHA512 1d19329f42a1dd4be69e250c31c7eea04facc05e03d1fe6a96ad5de43eeb2433fc5c82115c2b19818b6a4e063856c15143302fd0546ab8bc5b0ce95b5b2e3f2c
-MISC metadata.xml 236 BLAKE2B 5a64c4404c26415501f50132968e687d4f1b852738cb0e1a5aef8cc4de9e4ea623066f46068fce3d80514ff122d85304e3fd12282c4b1513a4084523ef8bef07 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253
diff --git a/dev-java/osgi-foundation/files/osgi-foundation-1.2.0-build.xml b/dev-java/osgi-foundation/files/osgi-foundation-1.2.0-build.xml
deleted file mode 100644
index a33f09709ada..000000000000
--- a/dev-java/osgi-foundation/files/osgi-foundation-1.2.0-build.xml
+++ /dev/null
@@ -1,218 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 5/11/13 9:36 AM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="org.osgi.foundation-from-maven" default="package" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environment properties -->
- <!-- ====================================================================== -->
-
- <property file="${user.home}/.m2/maven.properties"/>
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="org.osgi.foundation-1.2.0"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/resources"/>
- <property name="maven.build.resourceDir.1" value="."/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
- <property name="maven.settings.offline" value="false"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Defining classpaths -->
- <!-- ====================================================================== -->
-
- <path id="build.classpath"/>
- <path id="build.test.classpath">
- <pathelement location="${maven.repo.local}/junit/junit/3.8.1/junit-3.8.1.jar"/>
- <pathelement location="${maven.repo.local}/easymock/easymock/1.2_Java1.3/easymock-1.2_Java1.3.jar"/>
- </path>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" depends="get-deps" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.3"
- verbose="false"
- fork="false"
- source="1.3">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- <classpath refid="build.classpath"/>
- </javac>
- <mkdir dir="${maven.build.outputDir}/META-INF"/>
- <copy todir="${maven.build.outputDir}/META-INF">
- <fileset dir="${maven.build.resourceDir.1}">
- <include name="LICENSE*"/>
- <include name="NOTICE*"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="compile"
- description="Compile the test code"
- unless="maven.test.skip">
- <mkdir dir="${maven.build.testOutputDir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="compile-tests, junit-missing"
- unless="junit.skipped"
- description="Run the test cases"/>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="test-junit-status"
- depends="test-junit-present">
- <condition property="junit.missing">
- <and>
- <isfalse value="${junit.present}"/>
- <isfalse value="${maven.test.skip}"/>
- </and>
- </condition>
- <condition property="junit.skipped">
- <or>
- <isfalse value="${junit.present}"/>
- <istrue value="${maven.test.skip}"/>
- </or>
- </condition>
- </target>
-
- <target name="junit-missing"
- depends="test-junit-status"
- if="junit.missing">
- <echo>=================================== WARNING ===================================</echo>
- <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- linksource="false"
- breakiterator="false"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile,test" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Download dependencies target -->
- <!-- ====================================================================== -->
-
- <target name="test-offline">
- <condition property="maven.mode.offline">
- <equals arg1="${maven.settings.offline}" arg2="true"/>
- </condition>
- </target>
-
- <target name="get-deps"
- depends="test-offline"
- description="Download all dependencies"
- unless="maven.mode.offline">
- <mkdir dir="${maven.repo.local}"/>
- <mkdir dir="${maven.repo.local}/junit/junit/3.8.1"/>
- <get src="http://people.apache.org/repo/m2-snapshot-repository/junit/junit/3.8.1/junit-3.8.1.jar"
- dest="${maven.repo.local}/junit/junit/3.8.1/junit-3.8.1.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://repo.maven.apache.org/maven2/junit/junit/3.8.1/junit-3.8.1.jar"
- dest="${maven.repo.local}/junit/junit/3.8.1/junit-3.8.1.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <mkdir dir="${maven.repo.local}/easymock/easymock/1.2_Java1.3"/>
- <get src="http://people.apache.org/repo/m2-snapshot-repository/easymock/easymock/1.2_Java1.3/easymock-1.2_Java1.3.jar"
- dest="${maven.repo.local}/easymock/easymock/1.2_Java1.3/easymock-1.2_Java1.3.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- <get src="http://repo.maven.apache.org/maven2/easymock/easymock/1.2_Java1.3/easymock-1.2_Java1.3.jar"
- dest="${maven.repo.local}/easymock/easymock/1.2_Java1.3/easymock-1.2_Java1.3.jar"
- usetimestamp="false"
- ignoreerrors="true"/>
- </target>
-
-</project>
diff --git a/dev-java/osgi-foundation/metadata.xml b/dev-java/osgi-foundation/metadata.xml
deleted file mode 100644
index 952a4b9b605c..000000000000
--- a/dev-java/osgi-foundation/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-java/osgi-foundation/osgi-foundation-1.2.0-r1.ebuild b/dev-java/osgi-foundation/osgi-foundation-1.2.0-r1.ebuild
deleted file mode 100644
index de894898fc85..000000000000
--- a/dev-java/osgi-foundation/osgi-foundation-1.2.0-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="OSGi R4 Foundation EE by Apache Felix"
-HOMEPAGE="http://felix.apache.org/"
-SRC_URI="https://dev.gentoo.org/~tomwij/files/dist/${P}.tar.xz"
-
-LICENSE="Apache-2.0 OSGi-Specification-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-DEPEND=">=virtual/jdk-1.5"
-RDEPEND=">=virtual/jre-1.5"
-
-java_prepare() {
- cp "${FILESDIR}"/${P}-build.xml "${S}"/build.xml || die
-}
-
-src_install() {
- java-pkg_newjar target/org.osgi.foundation-${PV}.jar org.osgi.foundation.jar
-}