summaryrefslogtreecommitdiff
path: root/dev-java/spin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-java/spin
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/spin')
-rw-r--r--dev-java/spin/Manifest5
-rw-r--r--dev-java/spin/files/1.5-build.xml197
-rw-r--r--dev-java/spin/files/1.5-maven-build.properties16
-rw-r--r--dev-java/spin/metadata.xml11
-rw-r--r--dev-java/spin/spin-1.5-r1.ebuild48
5 files changed, 0 insertions, 277 deletions
diff --git a/dev-java/spin/Manifest b/dev-java/spin/Manifest
deleted file mode 100644
index 02fb35989864..000000000000
--- a/dev-java/spin/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX 1.5-build.xml 8638 BLAKE2B ef4667e88f82c6284c592574822b88fe66fc5ca22626fd12164be6e18315b139e18636420cb7bb832167fe26f2b2bbf48a2e928a169f094786d770816cfd157d SHA512 8126661b264cac4a86dfbd646a8e88598075173479d1d952dcaa3c756793394bb50ff1bd5a57f4a4a86cad99d4b49cd5bd398ad608fb199a12adeecb64228583
-AUX 1.5-maven-build.properties 673 BLAKE2B b014639d8fccc8845dc632a06b25f8a0a4c00ed96b76ac8d8ff74cc2957d98d56f585a53b2cd3028d1d9d6d9b0a96c3fc29dc85dddf21678d6e8f60fcbe73a6f SHA512 1004515f5a89a2d22409cd7553fb11767a4580d1288393516f4dc3c0efa0c149d7bc3e46fac93800e6481fc7885302730e52e9e518d6d7224a0d9220d0f3c3a2
-DIST spin-1.5-all.zip 482286 BLAKE2B d1b1de891290ed465f2886bea046d9aa106626be91e5ac37dcd795bb0ef5e558b3d81b1e86cfb168d660f4c2884d321d560bece50645822a0334848225c6638b SHA512 ce1fad3b138781359d472727b186722d6f1f23b7002dd1ada294efd80b3a9caf5de15207cdd682fcbfcafa85c63895c7dd9683fefb5ce5b09cc4115ae3733466
-EBUILD spin-1.5-r1.ebuild 1012 BLAKE2B dbcc56a3a70e6f85803ff8ed8872aff88d575831c437ae255030f3442abaf52eccc256b3bd9ac797e8f0c1d6abb76328abffaa1b222dd390bda8b31f7b33e58d SHA512 1e5a42026101717f93dcb30384bbedc74c222f5acc34042f09630df8ea3f869d9b6731526bc7af1e377a3ba7a7319f70bfe0bd769c12a4ff72bc01e715c4a707
-MISC metadata.xml 310 BLAKE2B 2bc43a823a410b7196f5e49bdeed6ee3c5dd46c81ac677b922fbed6f55375c59e3d16dee2b8943734f0e3ad6da29822ca6d8490dae29c22dc9407ae4b702e0e2 SHA512 4ed6297527aa1e31d6570464b166e1facdc53b2c2d89d2e062975d7230a1ea4623e90451ac25b521a0d9449fee8c27c255b23102601af1596a5998e3582ec8af
diff --git a/dev-java/spin/files/1.5-build.xml b/dev-java/spin/files/1.5-build.xml
deleted file mode 100644
index ac58aec49131..000000000000
--- a/dev-java/spin/files/1.5-build.xml
+++ /dev/null
@@ -1,197 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!-- ====================================================================== -->
-<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
-<!-- ====================================================================== -->
-
-<!-- ====================================================================== -->
-<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
-<!-- ====================================================================== -->
-<!-- -->
-<!-- Any modifications will be overwritten. -->
-<!-- -->
-<!-- Generated by Maven Ant Plugin on 4/20/07 5:09 PM -->
-<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
-<!-- -->
-<!-- ====================================================================== -->
-
-<project name="spin-from-maven" default="dist" basedir=".">
-
- <!-- ====================================================================== -->
- <!-- Build environnement properties -->
- <!-- ====================================================================== -->
-
- <property file="maven-build.properties"/>
-
- <property name="maven.build.finalName" value="spin-1.5"/>
- <property name="maven.build.dir" value="target"/>
- <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
- <property name="maven.build.srcDir.0" value="src/main/java"/>
- <property name="maven.build.resourceDir.0" value="src/main/java"/>
- <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
- <property name="maven.build.testDir.0" value="src/test/java"/>
- <property name="maven.build.testResourceDir.0" value="src/main/java"/>
- <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
- <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
-
- <property name="maven.settings.offline" value="true"/>
- <property name="maven.settings.interactiveMode" value="true"/>
-
- <!-- ====================================================================== -->
- <!-- Cleaning up target -->
- <!-- ====================================================================== -->
-
- <target name="clean" description="Clean the output directory">
- <delete dir="${maven.build.dir}"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile" description="Compile the code">
- <mkdir dir="${maven.build.outputDir}"/>
- <javac destdir="${maven.build.outputDir}" classpath="${gentoo.classpath}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.4"
- verbose="false"
- fork="false"
- source="1.4">
- <src>
- <pathelement location="${maven.build.srcDir.0}"/>
- </src>
- </javac>
- <copy todir="${maven.build.outputDir}">
- <fileset dir="${maven.build.resourceDir.0}">
- <include name="**/*"/>
- <exclude name="**/*.java"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Test-compilation target -->
- <!-- ====================================================================== -->
-
- <target name="compile-tests"
- depends="junit-present, compile"
- description="Compile the test code"
- if="junit.present">
- <mkdir dir="${maven.build.testOutputDir}"/>
- <javac destdir="${maven.build.testOutputDir}" classpath="${gentoo.classpath}"
- nowarn="false"
- debug="true"
- optimize="false"
- deprecation="true"
- target="1.4"
- verbose="false"
- fork="false"
- source="1.4">
- <src>
- <pathelement location="${maven.build.testDir.0}"/>
- </src>
- <classpath>
- <pathelement location="${maven.build.outputDir}"/>
- </classpath>
- </javac>
- <copy todir="${maven.build.testOutputDir}">
- <fileset dir="${maven.build.testResourceDir.0}">
- <include name="**/*"/>
- <exclude name="**/*.java"/>
- </fileset>
- </copy>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Run all tests -->
- <!-- ====================================================================== -->
-
- <target name="test"
- depends="junit-present, compile-tests"
- if="junit.present"
- description="Run the test cases">
- <mkdir dir="${maven.test.reports}"/>
- <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
- <sysproperty key="basedir" value="."/>
- <formatter type="xml"/>
- <formatter type="plain" usefile="false"/>
- <classpath>
- <pathelement path="${gentoo.classpath}"/>
- <pathelement location="${maven.build.outputDir}"/>
- <pathelement location="${maven.build.testOutputDir}"/>
- </classpath>
- <batchtest todir="${maven.test.reports}">
- <fileset dir="${maven.build.testDir.0}">
- <include name="**/*Test.java"/>
- <exclude name="**/*Abstract*Test.java"/>
- </fileset>
- </batchtest>
- </junit>
- </target>
-
- <target name="test-junit-present">
- <available classname="junit.framework.Test" property="junit.present"/>
- </target>
-
- <target name="junit-present"
- depends="test-junit-present"
- unless="junit.present">
- <echo>=================================== WARNING ===================================</echo>
- <echo> Junit isn&apos;t present in your $ANT_HOME/lib directory. Tests not executed. </echo>
- <echo>===============================================================================</echo>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Javadoc target -->
- <!-- ====================================================================== -->
-
- <target name="javadoc" description="Generates the Javadoc of the application">
- <javadoc sourcepath="${maven.build.srcDir.0}"
- packagenames="*"
- destdir="${maven.reporting.outputDirectory}/apidocs"
- access="protected"
- old="false"
- verbose="false"
- version="true"
- use="true"
- author="true"
- splitindex="false"
- nodeprecated="false"
- nodeprecatedlist="false"
- notree="false"
- noindex="false"
- nohelp="false"
- nonavbar="false"
- serialwarn="false"
- charset="ISO-8859-1"
- linksource="false"
- breakiterator="false"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- Package target -->
- <!-- ====================================================================== -->
-
- <target name="package" depends="compile" description="Package the application">
- <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
- compress="true"
- index="false"
- basedir="${maven.build.outputDir}"
- excludes="**/package.html"/>
- </target>
-
- <!-- ====================================================================== -->
- <!-- A dummy target for the package named after the type it creates -->
- <!-- ====================================================================== -->
-
- <target name="jar" depends="package" description="Builds the jar for the application"/>
-
- <!-- ====================================================================== -->
- <!-- Dist target -->
- <!-- ====================================================================== -->
-
- <target name="dist" depends="package,test" description="Package the application and run tests"/>
-</project> \ No newline at end of file
diff --git a/dev-java/spin/files/1.5-maven-build.properties b/dev-java/spin/files/1.5-maven-build.properties
deleted file mode 100644
index 1d9c9b68034b..000000000000
--- a/dev-java/spin/files/1.5-maven-build.properties
+++ /dev/null
@@ -1,16 +0,0 @@
-#Generated by Maven Ant Plugin - DO NOT EDIT THIS FILE!
-#Fri Apr 20 17:09:04 EEST 2007
-project.build.outputDirectory=${maven.build.outputDir}
-project.build.directory=${maven.build.dir}
-maven.test.reports=${maven.build.dir}/test-reports
-maven.build.finalName=spin-1.5
-maven.reporting.outputDirectory=${maven.build.dir}/site
-maven.build.testResourceDir.0=src/test/java
-maven.build.outputDir=${maven.build.dir}/classes
-maven.build.resourceDir.0=src/main/java
-maven.build.testOutputDir=${maven.build.dir}/test-classes
-maven.settings.offline=false
-maven.build.dir=target
-maven.settings.interactiveMode=true
-maven.build.testDir.0=src/test/java
-maven.build.srcDir.0=src/main/java
diff --git a/dev-java/spin/metadata.xml b/dev-java/spin/metadata.xml
deleted file mode 100644
index 28ae24c42657..000000000000
--- a/dev-java/spin/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">spin</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-java/spin/spin-1.5-r1.ebuild b/dev-java/spin/spin-1.5-r1.ebuild
deleted file mode 100644
index ba1292591bb0..000000000000
--- a/dev-java/spin/spin-1.5-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Transparent threading solution for non-freezing Swing applications"
-HOMEPAGE="http://spin.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}-all.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-COMMON_DEP="dev-java/cglib:3"
-DEPEND=">=virtual/jdk-1.6
- app-arch/unzip
- ${COMMON_DEP}"
-RDEPEND=">=virtual/jre-1.6
- ${COMMON_DEP}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- cp "${FILESDIR}/${PV}-build.xml" build.xml || die
- cp "${FILESDIR}/${PV}-maven-build.properties" maven-build.properties || die
- rm -v lib/*.jar || die
- java-pkg_filter-compiler jikes
-}
-
-EANT_GENTOO_CLASSPATH="cglib-3"
-
-# Needs X
-RESTRICT="test"
-
-src_test() {
- ANT_TASKS="ant-junit" eant test
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar
-
- use doc && java-pkg_dojavadoc target/site/apidocs
- use source && java-pkg_dosrc src/main/java/*
-}