summaryrefslogtreecommitdiff
path: root/dev-java/trident
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/trident
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/trident')
-rw-r--r--dev-java/trident/Manifest4
-rw-r--r--dev-java/trident/files/1.3-build.xml.patch29
-rw-r--r--dev-java/trident/metadata.xml8
-rw-r--r--dev-java/trident/trident-1.3.ebuild46
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-java/trident/Manifest b/dev-java/trident/Manifest
new file mode 100644
index 000000000000..0aad2d0124b4
--- /dev/null
+++ b/dev-java/trident/Manifest
@@ -0,0 +1,4 @@
+AUX 1.3-build.xml.patch 2112 BLAKE2B e014eb8632086256f7abf0068bc076b544dae4e4bcb1f8ffb7cd7ea132d87663f44e672aef93e6d18071d555486f9e526a70d2436d72c26c75592b82636310d1 SHA512 f4790f0f7551d2734c0db2495c1dff5f6580c1734aab596fd0e419447b8c085d3ba2b4010dea972e6e3c400141d619a10baed10a2d4b8f4135e9855e9ec9b6e6
+DIST trident-1.3.zip 112050 BLAKE2B 62f5ae9266714524c50e92c00d3d13810d47727596b0247786c056490b5366015fd35b2e859925734eae26c01b8070474d24e0770ac2eb644024f32754a6c5b7 SHA512 2ecccf80c654ad8cff6a2907d4f81409034bd5cc07542e87db7b53a646fb63ee38a472eb778f6f77f6cf1885f8dc5b85d50a6a033ab430e7e03a07000463f68b
+EBUILD trident-1.3.ebuild 998 BLAKE2B 8356f3bfcfc2e909b897738f4b40bf23e01eda8b8aa2aee5b8a62e8db2c6ff24ce849567e0a70260db1ca71a3a89e295ba7bf95884e1edc4c9bbdb3e790829ae SHA512 859285924da73f45e601a0cb9553e301f908718f79cce6ad104688fc8f9486f13324ea8cb8aaabe212184e0004671c01b9edede2ffcbc128787243159c804282
+MISC metadata.xml 236 BLAKE2B 5a64c4404c26415501f50132968e687d4f1b852738cb0e1a5aef8cc4de9e4ea623066f46068fce3d80514ff122d85304e3fd12282c4b1513a4084523ef8bef07 SHA512 1755c2590e59060f697294c5ad125b83f2d50e05a71f7091b7de75953941914cd2db3a893bd6154a2c90fa4aff5e313e75e3e174dbba1edd5c112787da5be253
diff --git a/dev-java/trident/files/1.3-build.xml.patch b/dev-java/trident/files/1.3-build.xml.patch
new file mode 100644
index 000000000000..c82c3a18df3f
--- /dev/null
+++ b/dev-java/trident/files/1.3-build.xml.patch
@@ -0,0 +1,29 @@
+diff --git a/build.xml b/build.xml
+index 808ea3c..36e5859 100644
+--- a/build.xml
++++ b/build.xml
+@@ -84,7 +84,7 @@
+
+ <target name="compile.module.trident.production" description="compile module trident production classes">
+ <mkdir dir="${trident.output.dir}" />
+- <javac source="${javac.source}" target="${javac.target}" encoding="${javac.encoding}" destdir="${trident.output.dir}" debug="${javac.debug}" nowarn="${javac.generate.no.warnings}" memoryMaximumSize="${javac.max.memory}" fork="true" executable="${module.jdk.home.trident}/bin/javac">
++ <javac source="${javac.source}" target="${javac.target}" encoding="${javac.encoding}" destdir="${trident.output.dir}" debug="${javac.debug}" nowarn="${javac.generate.no.warnings}" memoryMaximumSize="${javac.max.memory}" fork="true">
+ <compilerarg line="${javac.args.trident}" />
+ <bootclasspath refid="trident.module.bootclasspath" />
+ <classpath refid="trident.module.classpath" />
+@@ -102,7 +102,7 @@
+
+ <target name="compile.module.trident.test" description="compile module trident test classes">
+ <mkdir dir="${trident.output.dir}" />
+- <javac source="${javac.source}" target="${javac.target}" encoding="${javac.encoding}" destdir="${trident.output.dir}" debug="${javac.debug}" nowarn="${javac.generate.no.warnings}" memoryMaximumSize="${javac.max.memory}" fork="true" executable="${module.jdk.home.trident}/bin/javac">
++ <javac source="${javac.source}" target="${javac.target}" encoding="${javac.encoding}" destdir="${trident.output.dir}" debug="${javac.debug}" nowarn="${javac.generate.no.warnings}" memoryMaximumSize="${javac.max.memory}" fork="true">
+ <compilerarg line="${javac.args.trident}" />
+ <bootclasspath refid="trident.module.bootclasspath" />
+ <classpath refid="trident.module.classpath" />
+@@ -189,4 +189,4 @@
+ <target name="clean" depends="clean.module.trident" description="cleanup all" />
+
+ <target name="all" depends="timestamp, init, clean, compile.module.trident, jar, compile.module.trident.test, jar-tst" description="build all" />
+-</project>
+\ No newline at end of file
++</project>
diff --git a/dev-java/trident/metadata.xml b/dev-java/trident/metadata.xml
new file mode 100644
index 000000000000..952a4b9b605c
--- /dev/null
+++ b/dev-java/trident/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-java/trident/trident-1.3.ebuild b/dev-java/trident/trident-1.3.ebuild
new file mode 100644
index 000000000000..4310cd5b1f56
--- /dev/null
+++ b/dev-java/trident/trident-1.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java animation library"
+HOMEPAGE="https://kenai.com/projects/trident/pages/Home"
+SRC_URI="https://kenai.com/projects/trident/downloads/download/version%20${PV}%20-%20stable/${PN}-all.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RESTRICT="test"
+
+CDEPEND="dev-java/swt:3.7"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+S="${WORKDIR}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_BUILD_TARGET="timestamp init clean compile.module.trident jar"
+EANT_GENTOO_CLASSPATH="swt-3.7"
+EANT_EXTRA_ARGS="-Djdk.home=${JAVA_HOME}"
+
+java_prepare() {
+ mkdir build/classes -p || die
+ rm -r src/org/pushingpixels/trident/android/ || die
+ epatch "${FILESDIR}"/${PV}-*.patch
+}
+
+src_install() {
+ java-pkg_dojar drop/${PN}.jar
+
+ use source && java-pkg_dosrc src/*
+}