summaryrefslogtreecommitdiff
path: root/dev-java/txw2-runtime/txw2-runtime-20110809.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-java/txw2-runtime/txw2-runtime-20110809.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-java/txw2-runtime/txw2-runtime-20110809.ebuild')
-rw-r--r--dev-java/txw2-runtime/txw2-runtime-20110809.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-java/txw2-runtime/txw2-runtime-20110809.ebuild b/dev-java/txw2-runtime/txw2-runtime-20110809.ebuild
new file mode 100644
index 000000000000..331a381bf865
--- /dev/null
+++ b/dev-java/txw2-runtime/txw2-runtime-20110809.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="${PN%%-*}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="TXW is a library that allows you to write XML documents"
+HOMEPAGE="https://txw.dev.java.net/"
+SRC_URI="http://central.maven.org/maven2/com/sun/xml/${MY_PN}/${MY_PN}/${PV}/${MY_P}-sources.jar"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip"
+
+JAVA_SRC_DIR="com"