summaryrefslogtreecommitdiff
path: root/dev-java/univocity-parsers/univocity-parsers-2.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-java/univocity-parsers/univocity-parsers-2.9.1.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-java/univocity-parsers/univocity-parsers-2.9.1.ebuild')
-rw-r--r--dev-java/univocity-parsers/univocity-parsers-2.9.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/univocity-parsers/univocity-parsers-2.9.1.ebuild b/dev-java/univocity-parsers/univocity-parsers-2.9.1.ebuild
new file mode 100644
index 000000000000..d8a1215f2da3
--- /dev/null
+++ b/dev-java/univocity-parsers/univocity-parsers-2.9.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Some test dependencies have not been packaged yet
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="com.univocity:univocity-parsers:2.9.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A collection of extremely fast and reliable parsers for Java"
+HOMEPAGE="https://www.univocity.com/"
+SRC_URI="https://github.com/uniVocity/univocity-parsers/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+# Restore value of S overridden by java-pkg-simple.eclass to default
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src/main/java"
+
+src_prepare() {
+ # https://github.com/uniVocity/univocity-parsers/pull/502
+ eapply "${FILESDIR}/${P}-explicitly-import-Record.patch"
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ einstalldocs # https://bugs.gentoo.org/789582
+}