summaryrefslogtreecommitdiff
path: root/dev-java/velocity-dvsl/velocity-dvsl-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/velocity-dvsl/velocity-dvsl-1.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/velocity-dvsl/velocity-dvsl-1.0.ebuild')
-rw-r--r--dev-java/velocity-dvsl/velocity-dvsl-1.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/velocity-dvsl/velocity-dvsl-1.0.ebuild b/dev-java/velocity-dvsl/velocity-dvsl-1.0.ebuild
new file mode 100644
index 000000000000..42c7d261a5bc
--- /dev/null
+++ b/dev-java/velocity-dvsl/velocity-dvsl-1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source examples"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Declarative Velocity Style Language."
+HOMEPAGE="http://velocity.apache.org/dvsl/devel/"
+SRC_URI="mirror://apache/velocity/dvsl/${PV}/${P}-src.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RESTRICT="test"
+
+CDEPEND="
+ dev-java/ant-core:0
+ dev-java/dom4j:1
+ dev-java/velocity:0"
+
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_SRC_DIR="src"
+
+JAVA_GENTOO_CLASSPATH="
+ dom4j-1
+ ant-core
+ velocity
+"
+
+java_prepare() {
+ java-pkg_clean
+ rm -rv src/test || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher "${PN}" --main org.apache.dvsl.DVSL
+ use examples && java-pkg_doexamples examples
+}