summaryrefslogtreecommitdiff
path: root/dev-java/xsdlib/xsdlib-20090415.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-java/xsdlib/xsdlib-20090415.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-java/xsdlib/xsdlib-20090415.ebuild')
-rw-r--r--dev-java/xsdlib/xsdlib-20090415.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-java/xsdlib/xsdlib-20090415.ebuild b/dev-java/xsdlib/xsdlib-20090415.ebuild
new file mode 100644
index 000000000000..0ca67cf144de
--- /dev/null
+++ b/dev-java/xsdlib/xsdlib-20090415.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Sun XML Datatypes Library"
+HOMEPAGE="http://msv.java.net/"
+SRC_URI="http://java.net/downloads/msv/releases/${PN}.${PV}.zip"
+
+LICENSE="BSD Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/xerces:2
+ dev-java/relaxng-datatype:0"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4
+ app-arch/unzip"
+
+S="${WORKDIR}/${P}"
+
+java_prepare() {
+ find -name '*.jar' -exec rm -v {} + || die
+}
+
+JAVA_SRC_DIR="src src-apache"
+JAVA_GENTOO_CLASSPATH="relaxng-datatype,xerces-2"
+
+src_compile() {
+ java-pkg-simple_src_compile
+
+ local dir; for dir in ${JAVA_SRC_DIR}; do
+ pushd ${dir} > /dev/null || die
+ jar -uf "${S}"/${PN}.jar $(find -name '*.properties') || die
+ popd > /dev/null
+ done
+}
+
+src_install() {
+ java-pkg-simple_src_install
+
+ dodoc README.txt
+ dohtml HowToUse.html
+}