summaryrefslogtreecommitdiff
path: root/dev-lang/coffee-script
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-12 05:35:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-12 05:35:22 +0000
commitc1b4edfc987ed3d2b1f39cdf70d1b9a19e725616 (patch)
tree8bcb81da4787d5fa0f49486bd34de95aa0db76a4 /dev-lang/coffee-script
parenta3c403d854118e8ef0e2d661383445eb2d7ec732 (diff)
gentoo auto-resync : 12:02:2024 - 05:35:22
Diffstat (limited to 'dev-lang/coffee-script')
-rw-r--r--dev-lang/coffee-script/Manifest4
-rw-r--r--dev-lang/coffee-script/coffee-script-2.7.0.ebuild66
-rw-r--r--dev-lang/coffee-script/metadata.xml22
3 files changed, 85 insertions, 7 deletions
diff --git a/dev-lang/coffee-script/Manifest b/dev-lang/coffee-script/Manifest
index 046f1f435de2..fa2a646b063d 100644
--- a/dev-lang/coffee-script/Manifest
+++ b/dev-lang/coffee-script/Manifest
@@ -1,3 +1,5 @@
DIST coffee-script-2.5.1.tar.gz 2226483 BLAKE2B 5a2c5f93d46b111aeda63077f60992232a768008187ba0e41bec885184fbbbb91014620fca5d8e38cfdb5e88de483425d3d95c87779f27d7450de7cbe62b489b SHA512 99f11f0822ffc841552cf6c78a28d152554f070df6d1b729bdd17df8ba6faae6ed2ba9886f7ee13ccb316de698ab8624370287274611fe90bef033d9f76c5865
+DIST coffee-script-2.7.0.tar.gz 2271083 BLAKE2B b79f8a3f3edd60b43e4f09c940a6461819199edf9d16dcb7f555a0230c45a9d7c86d2467a3c126e436c23245adaa4c26518dc820c222ce87118217db1ff2c252 SHA512 1a3ce93f67c3361ce8c8c182e4a8170b05019b08557c14285ed7ed7620e501717d97a991f0ebb884845811fdc2d5d76ba5fe4a92adebc3a8b3331b483eded5ab
EBUILD coffee-script-2.5.1.ebuild 1436 BLAKE2B 4f84045fa2e4b96d7d8208dd34466717a54cc2defbac5fba78d06eba0571f6b3034bbd0a1418c75eca8f2af341053e5e591b8689f02ca6bb4060d852323a324d SHA512 29b3ca15c19bf400785272bbd5e25fe7184410eaced04b7e6c55868bc8d3c0bf344abc7239625395b218645b4395993d994caaad49d59eaeb21a0a704b97bfc8
-MISC metadata.xml 920 BLAKE2B a73ea962039cc6d91fb4c6eaef9eede928edb2054516950f40abe7e6ccc3f90e5c4ab308df5a0ae955dad48ba74c3ceb91688657a43b7515e0ca7a9a185bb940 SHA512 21cf5d15a85861804eda191b8d28c7c33307e215fc6ecd3a1d34d0351f42efc713b634c281c722d4bf9d5a70cf20bc753ddcd4cdb9b0e4003c8a33c51dab77ff
+EBUILD coffee-script-2.7.0.ebuild 1695 BLAKE2B 2d66fd0544c2767dada78b9bc4eb54130c4fcb99376096ea4a57617c32dadbaab595787317c7e2fdc354d849060d25003b0df6bf10c814f805f896aa80ae6523 SHA512 d1f9f4a3686f4aac78e4aaa74cae729bd6429bd286e17297b56d6143a92acc7428415dadcf43ea7fb9d1ee51971291fe1dc86e1173641ad7f058af1f017ca620
+MISC metadata.xml 1029 BLAKE2B 80a03e9afc372837720050fa60919afd6c751c7526777be5afae00a29ef6869d4f46ea873197f53669a2ce5f5c07503c79c3363977ac1c4f8970225af57b40e7 SHA512 a01e36d206d984c31fbfc9f8be0584313e932f0dc57bd5a07905336300449b42c9d5f2ec1253dd180aa72113eac5decda2273adb6a49c85dab91907e749adb0f
diff --git a/dev-lang/coffee-script/coffee-script-2.7.0.ebuild b/dev-lang/coffee-script/coffee-script-2.7.0.ebuild
new file mode 100644
index 000000000000..2f497e582b0f
--- /dev/null
+++ b/dev-lang/coffee-script/coffee-script-2.7.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="coffeescript"
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="A little language that compiles into javascript"
+HOMEPAGE="https://coffeescript.org/"
+SRC_URI="https://github.com/jashkenas/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# This package has a test suite (that works), but it requires a number
+# of NodeJS/NPM packages that aren't in the tree.
+IUSE="doc examples"
+
+RDEPEND="
+ net-libs/nodejs
+"
+
+DOC_CONTENTS="To enable installation alongside other tools the Gentoo
+maintainer decided to rename the \"cake\" executable to \"coffee-cake\"."
+
+src_install() {
+ local npm_module_dir="/usr/$(get_libdir)/node/${PN}"
+
+ insinto "${npm_module_dir}"
+ doins *.js package.json
+ doins -r lib
+ dodoc CONTRIBUTING.md README.md
+
+ if use examples ; then
+ # Users should be able to run the examples without having to copy
+ # them to another directory and decompress them.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r documentation/examples
+ fi
+
+ if use doc ; then
+ # It looks like "docs/v2" contains the output from all of the stuff
+ # under "documentation".
+ docinto "html"
+ dodoc -r docs/v2/*
+ fi
+
+ # The coffee and cake "binaries" use a relative path to find the lib
+ # directory, so we have to symlink them rather than use dobin().
+ exeinto "${npm_module_dir}/bin"
+ doexe bin/cake
+ doexe bin/coffee
+ dosym "${npm_module_dir}/bin/cake" "/usr/bin/coffee-cake"
+ dosym "${npm_module_dir}/bin/coffee" "/usr/bin/coffee"
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/dev-lang/coffee-script/metadata.xml b/dev-lang/coffee-script/metadata.xml
index 9e11308796b4..e80b9f6c65b7 100644
--- a/dev-lang/coffee-script/metadata.xml
+++ b/dev-lang/coffee-script/metadata.xml
@@ -1,13 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ CoffeeScript is a little language that compiles into JavaScript. Underneath
+ that awkward Java-esque patina, JavaScript has always had a gorgeous heart.
+ CoffeeScript is an attempt to expose the good parts of JavaScript in a
+ simple way. The golden rule of CoffeeScript is: "It's just JavaScript." The
+ code compiles one-to-one into the equivalent JS, and there is no
+ interpretation at runtime. You can use any existing JavaScript library
+ seamlessly from CoffeeScript (and vice-versa). The compiled output is
+ readable, pretty-printed, and tends to run as fast or faster than the
+ equivalent handwritten JavaScript.
+ </longdescription>
<upstream>
<remote-id type="github">jashkenas/coffeescript</remote-id>
</upstream>
- <longdescription>
- CoffeeScript is a little language that compiles into JavaScript. Underneath that awkward Java-esque patina, JavaScript has always had a gorgeous heart. CoffeeScript is an attempt to expose the good parts of JavaScript in a simple way.
-
- The golden rule of CoffeeScript is: "It's just JavaScript." The code compiles one-to-one into the equivalent JS, and there is no interpretation at runtime. You can use any existing JavaScript library seamlessly from CoffeeScript (and vice-versa). The compiled output is readable, pretty-printed, and tends to run as fast or faster than the equivalent handwritten JavaScript.
- </longdescription>
</pkgmetadata>