summaryrefslogtreecommitdiff
path: root/dev-lang/erlang/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-lang/erlang/files
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-lang/erlang/files')
-rw-r--r--dev-lang/erlang/files/erlang-23.1.2-ac2.70.patch99
1 files changed, 99 insertions, 0 deletions
diff --git a/dev-lang/erlang/files/erlang-23.1.2-ac2.70.patch b/dev-lang/erlang/files/erlang-23.1.2-ac2.70.patch
new file mode 100644
index 000000000000..3c3a119270dd
--- /dev/null
+++ b/dev-lang/erlang/files/erlang-23.1.2-ac2.70.patch
@@ -0,0 +1,99 @@
+--- a/lib/crypto/configure.in
++++ b/lib/crypto/configure.in
+@@ -26,10 +26,11 @@ dnl define([AC_CACHE_SAVE], )dnl
+ AC_INIT(vsn.mk)
+
+ if test -z "$ERL_TOP" || test ! -d "$ERL_TOP" ; then
+- AC_CONFIG_AUX_DIRS(autoconf)
++ :
++ AC_CONFIG_AUX_DIR(autoconf)
+ else
+ erl_top=${ERL_TOP}
+- AC_CONFIG_AUX_DIRS($erl_top/erts/autoconf)
++ AC_CONFIG_AUX_DIR(../../erts/autoconf)
+ fi
+
+ if test "X$host" != "Xfree_source" -a "X$host" != "Xwin32"; then
+--- a/lib/megaco/configure.in
++++ b/lib/megaco/configure.in
+@@ -26,10 +26,11 @@ dnl define([AC_CACHE_SAVE], )dnl
+ AC_INIT(vsn.mk)
+
+ if test -z "$ERL_TOP" || test ! -d $ERL_TOP ; then
+- AC_CONFIG_AUX_DIRS(autoconf)
++ :
++ AC_CONFIG_AUX_DIR(autoconf)
+ else
+ erl_top=${ERL_TOP}
+- AC_CONFIG_AUX_DIRS($erl_top/erts/autoconf)
++ AC_CONFIG_AUX_DIR(../../erts/autoconf)
+ fi
+
+ if test "X$host" != "Xfree_source" -a "X$host" != "Xwin32"; then
+--- a/lib/odbc/configure.in
++++ b/lib/odbc/configure.in
+@@ -26,10 +26,11 @@ dnl Process this file with autoconf to produce a configure script.
+ AC_INIT(c_src/odbcserver.c)
+
+ if test -z "$ERL_TOP" || test ! -d $ERL_TOP ; then
+- AC_CONFIG_AUX_DIRS(autoconf)
++ :
++ AC_CONFIG_AUX_DIR(autoconf)
+ else
+ erl_top=${ERL_TOP}
+- AC_CONFIG_AUX_DIRS($erl_top/erts/autoconf)
++ AC_CONFIG_AUX_DIR(../../erts/autoconf)
+ fi
+
+ if test "X$host" != "Xfree_source" -a "X$host" != "Xwin32"; then
+--- a/lib/snmp/configure.in
++++ b/lib/snmp/configure.in
+@@ -5,10 +5,11 @@ define([AC_CACHE_SAVE], )dnl
+ AC_INIT(vsn.mk)
+
+ if test -z "$ERL_TOP" || test ! -d $ERL_TOP ; then
+- AC_CONFIG_AUX_DIRS(autoconf)
++ :
++ AC_CONFIG_AUX_DIR(autoconf)
+ else
+ erl_top=${ERL_TOP}
+- AC_CONFIG_AUX_DIRS($erl_top/erts/autoconf)
++ AC_CONFIG_AUX_DIR(../../erts/autoconf)
+ fi
+
+ if test "X$host" != "Xfree_source" -a "X$host" != "Xwin32"; then
+--- a/lib/wx/configure.in
++++ b/lib/wx/configure.in
+@@ -20,7 +20,7 @@ dnl %CopyrightEnd%
+
+ AC_INIT()
+
+-AC_CONFIG_AUX_DIRS($srcdir/autoconf)
++AC_CONFIG_AUX_DIR($srcdir/autoconf)
+
+ AC_PREREQ(2.59)
+
+@@ -30,10 +30,11 @@ if test -f ./CONF_INFO; then
+ fi
+
+ if test -z "$ERL_TOP" || test ! -d $ERL_TOP ; then
++ :
+ AC_MSG_ERROR([ERL_TOP is not set])
+ else
+ erl_top=${ERL_TOP}
+- AC_CONFIG_AUX_DIRS($erl_top/erts/autoconf)
++ AC_CONFIG_AUX_DIR(../../erts/autoconf)
+ WX_BUILDING_INSIDE_ERLSRC=true
+ fi
+
+--- a/make/configure.in
++++ b/make/configure.in
+@@ -82,7 +82,7 @@ AC_SUBST(ERL_TOP)
+ dnl
+ dnl Aux programs are found in erts/autoconf
+ dnl
+-AC_CONFIG_AUX_DIR(${srcdir}/erts/autoconf)
++AC_CONFIG_AUX_DIR(../erts/autoconf)
+
+ dnl
+ dnl Figure out what we are running on. And in violation of autoconf