summaryrefslogtreecommitdiff
path: root/dev-lang/ghc/ghc-9.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-21 08:40:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-21 08:40:51 +0100
commit4dec1dfeca8e16b25934ff861c9eab7d1a8758a1 (patch)
tree6baa6667b5a6f8803404d9c87646bbaccbff3d41 /dev-lang/ghc/ghc-9.0.2.ebuild
parent766dae6306eab8ca7e982499e2cab68eb5ecb105 (diff)
gentoo auto-resync : 21:08:2022 - 08:40:51
Diffstat (limited to 'dev-lang/ghc/ghc-9.0.2.ebuild')
-rw-r--r--dev-lang/ghc/ghc-9.0.2.ebuild28
1 files changed, 6 insertions, 22 deletions
diff --git a/dev-lang/ghc/ghc-9.0.2.ebuild b/dev-lang/ghc/ghc-9.0.2.ebuild
index 5f55fd44965a..e0cd53611f2c 100644
--- a/dev-lang/ghc/ghc-9.0.2.ebuild
+++ b/dev-lang/ghc/ghc-9.0.2.ebuild
@@ -32,8 +32,10 @@ BIN_PV=${PV}
arch_binaries="$arch_binaries amd64? ( https://eidetic.codes/ghc-bin-${PV}-x86_64-pc-linux-gnu.tbz2 )"
#arch_binaries="$arch_binaries ia64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-ia64-fixed-fiw.tbz2 )"
#arch_binaries="$arch_binaries ppc? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-ppc.tbz2 )"
-#arch_binaries="$arch_binaries ppc64? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-ppc64.tbz2 )"
-arch_binaries="$arch_binaries ppc64? ( !big-endian? ( https://github.com/matoro/ghc/releases/download/${PV}/ghc-bin-${PV}-powerpc64le-unknown-linux-gnu.tar.gz ) )"
+arch_binaries="$arch_binaries ppc64? (
+ big-endian? ( https://github.com/matoro/ghc/releases/download/${PV}/ghc-bin-${PV}-powerpc64-unknown-linux-gnu.tar.gz )
+ !big-endian? ( https://github.com/matoro/ghc/releases/download/${PV}/ghc-bin-${PV}-powerpc64le-unknown-linux-gnu.tar.gz )
+)"
#arch_binaries="$arch_binaries sparc? ( https://slyfox.uni.cx/~slyfox/distfiles/ghc-bin-${PV}-sparc.tbz2 )"
arch_binaries="$arch_binaries x86? ( https://eidetic.codes/ghc-bin-${PV}-i686-pc-linux-gnu.tbz2 )"
@@ -49,9 +51,7 @@ yet_binary() {
amd64) return 0 ;;
#ia64) return 0 ;;
#ppc) return 0 ;;
- ppc64)
- use big-endian || return 0
- ;;
+ ppc64) return 0 ;;
#sparc) return 0 ;;
x86) return 0 ;;
*) return 1 ;;
@@ -506,30 +506,14 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-9.0.2-CHOST-prefix.patch
eapply "${FILESDIR}"/${PN}-9.0.2-darwin.patch
-
- # Incompatible with ghc-9.0.2-modorigin-semigroup.patch
- # Below patch should not be needed by ghc-9.2
- #eapply "${FILESDIR}"/${PN}-9.0.2-modorigin.patch
-
- # ModUnusable pretty-printing should include the reason
- #eapply "${FILESDIR}/${PN}-9.0.2-verbose-modunusable.patch"
-
# Fixes panic when compiling some packages
# https://github.com/gentoo-haskell/gentoo-haskell/issues/1250#issuecomment-1044257595
# https://gitlab.haskell.org/ghc/ghc/-/issues/21097
eapply "${FILESDIR}/${PN}-9.0.2-modorigin-semigroup.patch"
-
# Needed for testing with python-3.10
use test && eapply "${FILESDIR}/${PN}-9.0.2-fix-tests-python310.patch"
-
- #needs a port?
- #eapply "${FILESDIR}"/${PN}-8.8.1-revert-CPP.patch
eapply "${FILESDIR}"/${PN}-8.10.1-allow-cross-bootstrap.patch
- #eapply "${FILESDIR}"/${PN}-8.10.3-C99-typo-ac270.patch
-
- # a bunch of crosscompiler patches
- # needs newer version:
- #eapply "${FILESDIR}"/${PN}-8.2.1_rc1-hp2ps-cross.patch
+ eapply "${FILESDIR}"/${PN}-9.0.2-disable-unboxed-arrays.patch
# mingw32 target
pushd "${S}/libraries/Win32"