summaryrefslogtreecommitdiff
path: root/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild')
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild
index 3502c2c009fd..e0bcd6f39fb2 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2021-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -87,6 +87,11 @@ src_prepare() {
ln -s /usr/bin/$CHOST-ld \
"${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/ld \
|| die
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/as \
+ || die
+ ln -s /usr/bin/$CHOST-as \
+ "${WORKDIR}"/${BTSTRP}/libexec/gcc/x86_64-pc-linux-gnu/4.7.4/as \
+ || die
fi
CC=${GCC}
@@ -114,6 +119,9 @@ src_prepare() {
eapply "${FILESDIR}"/${P}-gentoo.patch
cd -
sed -i \
+ -e 's:-fcf-protection":":' \
+ lto-plugin/configure || die
+ sed -i \
-e 's:$(P) ::g' \
gcc/ada/gcc-interface/Makefile.in \
|| die "sed failed"