summaryrefslogtreecommitdiff
path: root/dev-lang/ispc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-07 00:11:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-07 00:11:16 +0000
commit1b2360e7bab42e4045232887cb4f6c4a24ca3975 (patch)
tree6a5a60c4c59058ef39895ea69fb8e98eaa49aed8 /dev-lang/ispc
parent22eaa60297c2dbc92dd1658fb7d8e46878552755 (diff)
gentoo auto-resync : 07:02:2025 - 00:11:15
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/Manifest2
-rw-r--r--dev-lang/ispc/ispc-1.26.0.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-lang/ispc/Manifest b/dev-lang/ispc/Manifest
index fcd0a9a67233..88658362e27b 100644
--- a/dev-lang/ispc/Manifest
+++ b/dev-lang/ispc/Manifest
@@ -1,3 +1,5 @@
DIST ispc-1.25.3.gh.tar.gz 19805596 BLAKE2B 6e98d2297b2b9b7da32c74328c0b3883a7bd7dc997624ed5c5eff1193779b28a29b6e505ec09f6ba471f0b3ba4b3c603561717311a370bad5350d7e898b9d5f1 SHA512 12bbf7b15d6ec97658d46d65d1c02103bdada4101dcaa2ebb5c8477c39934a588d1035371ae09636c0fa73267f4d714579b8fffcd8690d4f3d95eb12436908ab
+DIST ispc-1.26.0.gh.tar.gz 19849065 BLAKE2B db4f287dc0e2a6292875223dfe7b799cdd020384d505b60c13811b782bafd564a2adde4a5d1ca222efac77bfa218670af57dbd129e0d47db001b2c71e5f9aa61 SHA512 bb24cab35d3463b181da2b47ebf6c0836e82a5daff18b2edfccb0d83a066d2c70c30038391b4bcade5e3177bd004068c9ae8c523f09dcecb94d02a8b9e38a2c9
EBUILD ispc-1.25.3.ebuild 2085 BLAKE2B 35020de6dca6931fc0f089ad2d38017da2935094cea28070b9da0d3b6fd3ace3264f49072498f6aca4ca488cb3bd3f4915ba255824ed2c328b35b7ede1ad3462 SHA512 7959b1d591d171bf69063daa3f631fa5274c3277ccdb6e8538397c19770b94d1ecba64a1bd449e366431d276aa3ce3a9f37a8dc87aefa90f0c3d63049421b18b
+EBUILD ispc-1.26.0.ebuild 2086 BLAKE2B 4f5eb95d0743efe940312f057fc2cac586622958b0f86cd9349973448f3b20bc869cc7a3a0f7518696877a6bdb7187d13443f673ed6bbae5b72fba2cf76baa0c SHA512 2bf0e448f523ff9b282230f4d80396a969ecfd6ede03d7ab3e5e8ed62ac58d6f907b4a98b37e94e4ef28f84bb1fb98ad0616568278e5acf835251de619d12c63
MISC metadata.xml 509 BLAKE2B b605dfbff352fab4fcc58ad46f89f97d5db8522de237a0623021c521231798ad00b2b8cd82ce6840d86cfebbe185e6e767e8d0ec276b03a68554ecad20e6b96d SHA512 eae5fcfb0d56190f969ac83012624965b00bd757d8be0bbafce74ab1ea119dc4ee0c33076dd447fabf0a6a6d5f1e2783b54f6c59ebd7aa0a35a4a27df7db01f9
diff --git a/dev-lang/ispc/ispc-1.26.0.ebuild b/dev-lang/ispc/ispc-1.26.0.ebuild
new file mode 100644
index 000000000000..907a6ee9849a
--- /dev/null
+++ b/dev-lang/ispc/ispc-1.26.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LLVM_COMPAT=( {17..19} )
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit cmake llvm-r1 multiprocessing python-any-r1 toolchain-funcs
+
+DESCRIPTION="Intel SPMD Program Compiler"
+HOMEPAGE="
+ https://ispc.github.io/
+ https://github.com/ispc/ispc/
+"
+SRC_URI="
+ https://github.com/ispc/ispc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD BSD-2 UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="examples gpu openmp test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ $(llvm_gen_dep '
+ llvm-core/clang:${LLVM_SLOT}
+ ')
+ sys-libs/ncurses:=
+ gpu? ( dev-libs/level-zero:= )
+ !openmp? ( dev-cpp/tbb:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ app-alternatives/yacc
+ app-alternatives/lex
+ ${PYTHON_DEPS}
+"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ llvm-r1_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # do not require bundled gtest
+ mkdir -p ispcrt/tests/vendor/google/googletest || die
+ cat > ispcrt/tests/vendor/google/googletest/CMakeLists.txt <<-EOF || die
+ find_package(GTest)
+ EOF
+ # remove hacks that break unbundling
+ sed -i -e '/gmock/d' -e '/install/,$d' ispcrt/tests/CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DARM_ENABLED=$(usex arm)
+ -DCMAKE_SKIP_RPATH=ON
+ -DISPC_INCLUDE_EXAMPLES=OFF
+ -DISPC_INCLUDE_TESTS=$(usex test)
+ -DISPC_INCLUDE_UTILS=OFF
+ -DISPCRT_BUILD_GPU=$(usex gpu)
+ -DISPCRT_BUILD_TASK_MODEL=$(usex openmp OpenMP TBB)
+ # prevent it from trying to find the git repo
+ -DGIT_BINARY=GIT_BINARY-NOTFOUND
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # Inject path to prevent using system ispc
+ local -x PATH="${BUILD_DIR}/bin:${PATH}"
+ "${EPYTHON}" ./scripts/run_tests.py "-j$(makeopts_jobs)" -v ||
+ die "Testing failed under ${EPYTHON}"
+}
+
+src_install() {
+ cmake_src_install
+
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}