summaryrefslogtreecommitdiff
path: root/dev-lang/ispc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-24 14:02:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-24 14:02:21 +0000
commit9aefa814d833d6bdd1bdbc7d0f44d5680c9beaa8 (patch)
treeb70c1d27324b2ed33e5688d4a21f6c5195032ecf /dev-lang/ispc
parent1cf3f23200484257eaf7d863e323e7e9aee98d2b (diff)
gentoo auto-resync : 24:12:2022 - 14:02:21
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/Manifest1
-rw-r--r--dev-lang/ispc/files/ispc-9999-llvm.patch42
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-lang/ispc/Manifest b/dev-lang/ispc/Manifest
index 43cad783a58e..55a6ef4aaa53 100644
--- a/dev-lang/ispc/Manifest
+++ b/dev-lang/ispc/Manifest
@@ -1,6 +1,5 @@
AUX ispc-1.18.0-curses-cmake.patch 597 BLAKE2B 083a949e99a00819b1eed3ecb4276c7018f914a4902ea4c41dbd2a10c934d908ef2bc29a45e869ce290d5e787a7642de1ed630bc697b02e07267bb4e848fa1fc SHA512 6ba529e8dd4ce1483149e51a9a8ed28b476f604fcec263f806be7f9ec1b55decf8603126ea70600dce3d6947a328d907d046d25cc401847f6701cc9741d6cd14
AUX ispc-1.18.0-llvm.patch 1410 BLAKE2B 77027da9032fa230c72d8608c2a6cd63c33601e17acab0260101c64dbb50a0aa3cc30702c4480ae5d63e95ec3e962e28bdbbd90cd72f4e91d30dc364b82367b6 SHA512 116078d5ab99c849584cc4ece8dc3ebc817221a2377e26083071e206b5e83c4f3ed594f84b86c9659ef86a497bd3cd058ee32138238e12e6aa9dac0f11cf1440
-AUX ispc-9999-llvm.patch 1688 BLAKE2B 1eb6cfa4a8c42bed5e5472a0e81962edb4d823af34f67025a782833a5211c3e9925a68d0fd7137ad58ff21f113fe9cfedac47c29d04dad7c1c934d4fc7f238f3 SHA512 8f986ef14bb138a8777c6d82bbb0519a6722eb34fcda86107b268d5e63c7283cdc1242162fad57080a4cb32e0ddd0fa0010400211cd731df63aeeb6f198e26b7
DIST ispc-1.17.0.tar.gz 19436681 BLAKE2B 11af6e22c4c297a2fbd0ae1bfe2a37ce2f836607b2caf42634cff0b0fe1116542e71f056de12e3472724db04f1c5174c0deb47c2bd64fb756b4bdaef48935707 SHA512 b1c67381bb8b71d268c6e68c95cc5e2d64411ce351506de96d31850b879f7777fbc1cb33f3761437f84e52ae726fabbb794ebba9cf05d5200acaca07a2ebf0ac
DIST ispc-1.18.0.tar.gz 19469764 BLAKE2B dd95ec177120899066d5539add0f35685d73f65512e8be1cc42cf6725741d7f307fbecefc22c4944d9be0e3659d511546b15506213f3dbb97829953507996283 SHA512 350b43876d6885ab4c5c0d49c5b44323fd258d5cf7c68fcdea774baa92589542f2caeea93c347a37f0dab3dcf14e7b3e685973b41694f08ce7a2da64dc81bf06
EBUILD ispc-1.17.0-r2.ebuild 1649 BLAKE2B 5547751ed9b2631c4ea5b1466d9580a98b16d92e191e85d16fe71cbb04dd28acc05818c52b9bccd2893e487902d074ed1678af12294f3968acbf02813ef57eba SHA512 f979e3d8cbf68d2c40f0c9169d7a5037c444dcb914592e49daf4a04de7cd46f72c4eb03d18a237fe5508eeb787055cb4122d9ee31f4420d83771c99c844ab339
diff --git a/dev-lang/ispc/files/ispc-9999-llvm.patch b/dev-lang/ispc/files/ispc-9999-llvm.patch
deleted file mode 100644
index 934d9eaf5a60..000000000000
--- a/dev-lang/ispc/files/ispc-9999-llvm.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 13e66268..27ff8364 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -218,10 +218,7 @@ if (WASM_ENABLED)
- list(APPEND ISPC_TARGETS wasm-i32x4)
- endif()
-
--set(CLANG_LIBRARY_LIST clangFrontend clangDriver clangSerialization clangParse clangSema clangAnalysis clangAST clangBasic clangEdit clangLex)
-+set(CLANG_LIBRARY_LIST clang clang-cpp)
--if (${LLVM_VERSION_NUMBER} VERSION_GREATER_EQUAL "15.0.0")
-- list(APPEND CLANG_LIBRARY_LIST clangSupport)
--endif()
- set(LLVM_COMPONENTS engine ipo bitreader bitwriter instrumentation linker option frontendopenmp)
- if (${LLVM_VERSION_NUMBER} VERSION_GREATER_EQUAL "15.0.0")
- # windowsdriver is a small library introduced in LLVM 15. While it's targeted at Windows only,
-@@ -402,11 +402,8 @@ if (ISPC_USE_ASAN)
- endif()
-
- # Link against Clang libraries
--foreach(clangLib ${CLANG_LIBRARY_LIST})
-- find_library(${clangLib}Path NAMES ${clangLib} HINTS ${LLVM_LIBRARY_DIRS})
-- list(APPEND CLANG_LIBRARY_FULL_PATH_LIST ${${clangLib}Path})
--endforeach()
--target_link_libraries(${PROJECT_NAME} ${CLANG_LIBRARY_FULL_PATH_LIST})
-+find_package(Clang REQUIRED)
-+target_link_libraries(${PROJECT_NAME} ${CLANG_LIBRARY_LIST})
-
- # Link against LLVM libraries
- target_link_libraries(${PROJECT_NAME} ${LLVM_LIBRARY_LIST} ${CMAKE_DL_LIBS})
-diff --git a/src/llvmutil.cpp b/src/llvmutil.cpp
-index 06fab989..57a7130f 100644
---- a/src/llvmutil.cpp
-+++ b/src/llvmutil.cpp
-@@ -42,6 +42,7 @@
- #include <llvm/IR/BasicBlock.h>
- #include <llvm/IR/Instructions.h>
- #include <llvm/IR/Module.h>
-+#include <llvm/Support/raw_ostream.h>
-
- #ifdef ISPC_GENX_ENABLED
- #include <llvm/GenXIntrinsics/GenXIntrinsics.h>