summaryrefslogtreecommitdiff
path: root/dev-lang/jimtcl/jimtcl-0.75.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-lang/jimtcl/jimtcl-0.75.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-lang/jimtcl/jimtcl-0.75.ebuild')
-rw-r--r--dev-lang/jimtcl/jimtcl-0.75.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-lang/jimtcl/jimtcl-0.75.ebuild b/dev-lang/jimtcl/jimtcl-0.75.ebuild
new file mode 100644
index 000000000000..59a5c92d1924
--- /dev/null
+++ b/dev-lang/jimtcl/jimtcl-0.75.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit multilib
+
+DESCRIPTION="Small footprint implementation of Tcl programming language"
+HOMEPAGE="http://jim.tcl.tk"
+SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~s390 ~sh ~x86"
+IUSE="doc static-libs"
+DEPEND="doc? ( app-text/asciidoc )
+ app-arch/unzip"
+
+GIT_HASH="cffd1a5"
+S="${WORKDIR}"/msteveb-${PN}-${GIT_HASH}
+
+src_configure() {
+ ! use static-libs && myconf=--with-jim-shared
+ econf ${myconf}
+}
+
+src_compile() {
+ emake all
+ use doc && emake docs
+}
+
+src_install() {
+ dobin jimsh
+ use static-libs && {
+ dolib.a libjim.a
+ } || {
+ dolib.so libjim.so.${PV}
+ dosym /usr/$(get_libdir)/libjim.so.${PV} \
+ /usr/$(get_libdir)/libjim.so
+ }
+ insinto /usr/include
+ doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h
+ doins jim-win32compat.h jim-eventloop.h jim-config.h
+ dodoc AUTHORS README TODO
+ use doc && dohtml Tcl.html
+}