summaryrefslogtreecommitdiff
path: root/dev-lang/jwasm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-12 00:08:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-12 00:08:13 +0100
commitf0ddcad13515f66d2f3bf827d33c277bdba7e1dd (patch)
tree3e1da8fa4626163bda62e9e8b6129867de5be46d /dev-lang/jwasm
parent65ff3cc3bd9c3f8e718a67dfecf1f8215bf5d1d4 (diff)
gentoo auto-resync : 12:06:2024 - 00:08:13
Diffstat (limited to 'dev-lang/jwasm')
-rw-r--r--dev-lang/jwasm/Manifest3
-rw-r--r--dev-lang/jwasm/files/makefile-dep-fix.patch22
-rw-r--r--dev-lang/jwasm/jwasm-2.13.ebuild7
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-lang/jwasm/Manifest b/dev-lang/jwasm/Manifest
index 2f2684d1785c..cbab8bb00264 100644
--- a/dev-lang/jwasm/Manifest
+++ b/dev-lang/jwasm/Manifest
@@ -1,4 +1,5 @@
AUX jwasm-2.11-types-test.patch 1761 BLAKE2B b719bb79504e708925bfa407e72df7a37044b834bc3118fa9baf1a0cb478a0ab852872147148462188324954ef958af30cbcbca28fc992660276a15100ecb1b6 SHA512 0a4f3e613c8e724939ce9e23f8f4ce10ca89bf6c1579929719b3ccad62ac66cceecc3f8799c20c2875b7d4dcc7390bf0e4ca64aa08aab0b39bd7a4ab381b150b
+AUX makefile-dep-fix.patch 497 BLAKE2B d0fc87c0aff19689efa2440c7d90d3f0d7c80310e40dad6f4dd938e139d5458b5e4ae72153cb38242ae683c887ce085494f358e3f67c2be028adeadf176403ac SHA512 29526a14d7a6bc775d6cd590b1c75a864eb04c365de736e93c810d715760ac4d76b6691f05f9077adec9c6938aefa8637d6efd9db67c81752e604308fffd64e6
DIST jwasm-2.13.tar.gz 578365 BLAKE2B 8c6fbe3e6cb56c0fe8135c30c629534d2b6e2a2ed534249834e0e2674bf6635cb15ab94d4fa05c5378cb0db8569ddc3ba49d2d7c9615b7ddb769cba1a2d5b715 SHA512 03f80f4a74b39c6093f5cd5334364f7458836a52ad01279c95683e7053cb4211c40235e16f6f2ee40bc7316dcd8a4fbcb57bf3606d31249d96d01933a8aa0563
-EBUILD jwasm-2.13.ebuild 730 BLAKE2B c54d0438b6fcb0d339ae7b8d10a9948b2099c8db3b5f3e68a521d75979d3b6b51eab780530eb67d6e84af6ebe6e9b9c76464cebf1fb7a0d7e6a2d8dfd8c91464 SHA512 7269d7e817d3348b794878bc57fc729d14142c97adc0022adf1fd82eb3447a037127e0d44ae90f1baaa44a4966053f1b41e3043e8e009aa61594a4876df59807
+EBUILD jwasm-2.13.ebuild 771 BLAKE2B 249ed2462c3eddafd5e78580a41d3837d9187481272007ec100d4e514866743de09888ee1dcee89adadfc4a3f773bc8d3cbcfdd59606ea5ecaa63158b9c678f1 SHA512 ce900c45292c5cbcec98a1c4f357005b40b59fba8e50ae961a72383f00dac0a920a8dc70f38e070b1038b47142f1eab9f65ef8ad1422053e7a5c1b1257fc08c2
MISC metadata.xml 294 BLAKE2B 27e182db85c289075151811df775761aa9d9ed661474dcc710e084d3c325924d88b1c57389554a65383de3acf15ec4cce9a18e8cbffdd2a9230212279dad9174 SHA512 ef96dd7f6948e978281b5259ff6392aa72c90a672f4eef3394feece7e6c39c1ab96b42b8a2bbc3645dcb0d036778ac83055c9b76656f8d03f0a27dbf60084a0c
diff --git a/dev-lang/jwasm/files/makefile-dep-fix.patch b/dev-lang/jwasm/files/makefile-dep-fix.patch
new file mode 100644
index 000000000000..1b97a7c5aca4
--- /dev/null
+++ b/dev-lang/jwasm/files/makefile-dep-fix.patch
@@ -0,0 +1,22 @@
+Bug: https://bugs.gentoo.org/881519
+
+diff --git a/GccUnix.mak b/GccUnix.mak
+index 3f53d5b..8eb434e 100644
+--- a/GccUnix.mak
++++ b/GccUnix.mak
+@@ -31,13 +31,13 @@ include gccmod.inc
+
+ #.c.o:
+ # $(CC) -c $(inc_dirs) $(c_flags) -o $(OUTD)/$*.o $<
+-$(OUTD)/%.o: %.c
++$(OUTD)/%.o: %.c | $(OUTD)
+ $(CC) -c $(inc_dirs) $(c_flags) -o $(OUTD)/$*.o $<
+
+ all: $(OUTD) $(OUTD)/$(TARGET1)
+
+ $(OUTD):
+- mkdir $(OUTD)
++ mkdir -p $(OUTD)
+
+ $(OUTD)/$(TARGET1) : $(OUTD)/main.o $(proj_obj)
+ ifeq ($(DEBUG),0)
diff --git a/dev-lang/jwasm/jwasm-2.13.ebuild b/dev-lang/jwasm/jwasm-2.13.ebuild
index ecb666549892..0242aa2b604c 100644
--- a/dev-lang/jwasm/jwasm-2.13.ebuild
+++ b/dev-lang/jwasm/jwasm-2.13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,10 @@ BDEPEND=""
S="${WORKDIR}/JWasm-${PV}"
-PATCHES=("${FILESDIR}"/${PN}-2.11-types-test.patch)
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.11-types-test.patch
+ "${FILESDIR}/makefile-dep-fix.patch"
+)
src_prepare() {
default