summaryrefslogtreecommitdiff
path: root/dev-lang/micropython/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-lang/micropython/files
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-lang/micropython/files')
-rw-r--r--dev-lang/micropython/files/micropython-1.17-exclude-float-parse-tests.patch11
-rw-r--r--dev-lang/micropython/files/micropython-1.17-prevent-stripping.patch12
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-lang/micropython/files/micropython-1.17-exclude-float-parse-tests.patch b/dev-lang/micropython/files/micropython-1.17-exclude-float-parse-tests.patch
new file mode 100644
index 000000000000..8f44d31fd96f
--- /dev/null
+++ b/dev-lang/micropython/files/micropython-1.17-exclude-float-parse-tests.patch
@@ -0,0 +1,11 @@
+--- a/tests/run-tests.py 2021-10-25 12:25:48.422212212 -0000
++++ b/tests/run-tests.py 2021-10-25 12:26:01.382135667 -0000
+@@ -521,6 +521,8 @@
+ "micropython/opt_level_lineno.py"
+ ) # native doesn't have proper traceback info
+ skip_tests.add("micropython/schedule.py") # native code doesn't check pending events
++ skip_tests.add("float/float_parse_doubleprec.py")
++ skip_tests.add("float/float_parse.py")
+
+ def run_one_test(test_file):
+ test_file = test_file.replace("\\", "/")
diff --git a/dev-lang/micropython/files/micropython-1.17-prevent-stripping.patch b/dev-lang/micropython/files/micropython-1.17-prevent-stripping.patch
new file mode 100644
index 000000000000..1c5380ed883b
--- /dev/null
+++ b/dev-lang/micropython/files/micropython-1.17-prevent-stripping.patch
@@ -0,0 +1,12 @@
+--- a/py/mkrules.mk 2021-10-25 12:30:13.723695503 -0000
++++ b/py/mkrules.mk 2021-10-25 12:30:18.460327366 -0000
+@@ -198,9 +198,6 @@
+ # Do not pass COPT here - it's *C* compiler optimizations. For example,
+ # we may want to compile using Thumb, but link with non-Thumb libc.
+ $(Q)$(CC) -o $@ $^ $(LIB) $(LDFLAGS)
+-ifndef DEBUG
+- $(Q)$(STRIP) $(STRIPFLAGS_EXTRA) $@
+-endif
+ $(Q)$(SIZE) $$(find $(BUILD) -path "$(BUILD)/build/frozen*.o") $@
+
+ clean: clean-prog