summaryrefslogtreecommitdiff
path: root/dev-lang/nasm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
commit490ef2c2dc8b4e808f37add1adee21a754efd9a9 (patch)
treee235cdf15550b3d2f644b6fc4a8aa726971416f5 /dev-lang/nasm
parentda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (diff)
gentoo auto-resync : 21:04:2024 - 12:05:28
Diffstat (limited to 'dev-lang/nasm')
-rw-r--r--dev-lang/nasm/Manifest2
-rw-r--r--dev-lang/nasm/nasm-2.16.03.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-lang/nasm/Manifest b/dev-lang/nasm/Manifest
index 89bbfd9df0ca..ac47ec1a3834 100644
--- a/dev-lang/nasm/Manifest
+++ b/dev-lang/nasm/Manifest
@@ -3,6 +3,8 @@ AUX nasm-2.16-autoconf-macro-fixes.patch 8841 BLAKE2B b60d26d6f3b6b9775e5c12a5d3
AUX nasm-2.16.02-unconfig.patch 404 BLAKE2B 9a66c0b72b6d4a00c4af96f6cce1b645c1824ce2369ab528c3a3b1043b81d231a032988891f38092107c2b9a260ec2fa5003b50d281ab6ebd21ee924d074303a SHA512 8520c4bd9350ab0fe84b2828f253cebc3f53cd4af710ef4eb95acf1cf01c534df67ace340d3ea72a173cc5ec77880b66c833537732318d64fb9cadfbf46d695b
DIST nasm-2.16.01.tar.xz 1017732 BLAKE2B 0f7e96648e3db6fa4a8e10a89885f61cab7d79af25adbcc9d4706b3af61206c3cae024b7f873d636f5c1b2cb34ce5e7fbecc16af9b59086e9a1f49fb37c59670 SHA512 51fccb5639ce019d9c423c0f279750ffbd74c64cd41dd3b185d1aa1a1aaed79c5d3cd8d4bebbc13ee249a375ed27457ea2abde1a4dbb24d354598fffd1254833
DIST nasm-2.16.02.tar.xz 1044824 BLAKE2B daa3585e9aef3c388e3b577a52453b31aaa7f13942e621c21bbe6ec744ff30bf2692e853dda193b30006989cb10e40dcc1cf0107176e31fd5ee096baad28c7a1 SHA512 9ccafb4cd9064fb21f6551309d35ba7461de8da138b1239d76c2ea0c070a1a767f1019d5d705088375d625cfb73eebbfd9dfa3588107793b95354d89dcfd22c3
+DIST nasm-2.16.03.tar.xz 1032388 BLAKE2B 742cbf330341fde9f778d8ca13e8c06199f48796d47028ac973d39e3d9e434450cdfebe89f6ab248d372bdaeb0c88a25eb7153a39b66fc05e770523d4c9e11e9 SHA512 0c706e41a9c33e1ac3bad5056e8bf8cbcd51785b551a6e34ce7d0d723df8eaab8603a033e89b3dcda1004b558f9e9ef3196691500f10d8201bf47a323a516f84
EBUILD nasm-2.16.01-r1.ebuild 1581 BLAKE2B 0dcfc4b92ff0462b0e21c6b5f4144098f79130bd968f2808f3ce5afca27e23638496ee276a6cfdb81ffd85fd7e314db8036be60cec1db7f4b398aeb9f8cf0a17 SHA512 06d03935a76a8bb160914f6a0c76137b60364451d7275ceb613dc5bfb029044ede6e87d6a9cae5e25be3d5ba06f3aa9ae306786ba80f078f1e243f90181a6347
EBUILD nasm-2.16.02.ebuild 1951 BLAKE2B 790570970fa932ecce625160956a727a6ba19bac514ec8732267a581c6579a73782c22fb80a5873ffe3d68f65709547d4b29f2378cd87546578d20bf1a811714 SHA512 745fb377ef4bb08c263119c6835e5e8f672d975056a8d0d2b1edd2ac2fb1bde7f670b7ecdcdf8162333dfb776e41f59c31f9c42cde025f77890cef35d2fdfa0e
+EBUILD nasm-2.16.03.ebuild 2001 BLAKE2B 24fdb5670d037e5e15c847abf9db2186c39ed6dc67ac125d133347a64131d5757358e609d60c07eedaeee660eb193a41ef33deb90020a471c05821142c095974 SHA512 d652343f4a71c0c2ca0fcd57541d7c4dadf74b13d0ec58e3d7418819f3511af03b1628df7ad15da422f5bab6aa507ad102c0095940620e384225adb50c6ff52c
MISC metadata.xml 879 BLAKE2B 17d2ca1a78ed46d24fe75188387da9c03dafcd6aacf0db7c82fdee39ad766dac23010b6c51c90c08a3e591e93589a29a151ac5bc52fd6b3911504f2f124da6b7 SHA512 d6e921fc48851be64d1dfc0be200a1a86842e5d4d00a9f4551e7ca76a91272dc5f1f01928d3656a5e340283c83f7283bb9e7094c0309406d9392d57048239563
diff --git a/dev-lang/nasm/nasm-2.16.03.ebuild b/dev-lang/nasm/nasm-2.16.03.ebuild
new file mode 100644
index 000000000000..4c03189e21b1
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.16.03.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="https://www.nasm.us/"
+SRC_URI="https://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+S="${WORKDIR}"/${P/_}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc lto"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # Windows.
+ _BitScanReverse
+ _BitScanReverse64
+
+ # Linux headers that are not included.
+ __cpu_to_le16
+ __cpu_to_le32
+ __cpu_to_le64
+ _byteswap_uint64
+ _byteswap_ulong
+ _byteswap_ushort
+ cpu_to_le16
+ cpu_to_le32
+ cpu_to_le64
+
+ # __typeof as gnu extensions are not enabled
+ typeof
+
+ # musl doesn't define __bswap_N in endian.h (it's named _bswapN
+ # instead). could be fixed to call this instead, or to include
+ # musl's byteswap.h instead, but it is much easier to fall back on
+ # __builtin_bswapN. Bug #928848
+ __bswap_16
+ __bswap_32
+ __bswap_64
+)
+
+# [fonts note] doc/psfonts.ph defines ordered list of font preference.
+# Currently 'media-fonts/source-pro' is most preferred and is able to
+# satisfy all 6 font flavours: tilt, chapter, head, etc.
+BDEPEND="
+ dev-lang/perl
+ doc? (
+ app-text/ghostscript-gpl
+ dev-perl/Font-TTF
+ dev-perl/Sort-Versions
+ media-fonts/source-code-pro
+ media-fonts/source-sans:3
+ virtual/perl-File-Spec
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.15-bsd-cp-doc.patch
+)
+
+src_prepare() {
+ default
+
+ # https://bugs.gentoo.org/870214
+ # During the split of media-fonts/source-pro, the source-sans files
+ # were renamed. Currently depend on media-fonts/source-sans:3 which works
+ # with this sed.
+ sed -i 's/SourceSansPro/SourceSans3/g' doc/psfonts.ph || die
+
+ AT_M4DIR="${S}/autoconf/m4" eautoreconf
+}
+
+src_configure() {
+ local myconfargs=(
+ $(use_enable lto)
+ )
+ econf "${myconfargs[@]}"
+}
+
+src_compile() {
+ default
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install $(usex doc install_doc '')
+}