summaryrefslogtreecommitdiff
path: root/dev-lang/nelua/nelua-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-29 18:57:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-29 18:57:21 +0000
commit8455eae17683fbd2c785ca4b8443581622f388c7 (patch)
tree51bb7aac8b41b8f6e692f9e5b4e65001315b43fd /dev-lang/nelua/nelua-99999999.ebuild
parentb2f1788f6f0365b76f55f257b2d170c1e68a8640 (diff)
gentoo auto-resync : 29:01:2024 - 18:57:21
Diffstat (limited to 'dev-lang/nelua/nelua-99999999.ebuild')
-rw-r--r--dev-lang/nelua/nelua-99999999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-lang/nelua/nelua-99999999.ebuild b/dev-lang/nelua/nelua-99999999.ebuild
new file mode 100644
index 000000000000..1c9a4a93c841
--- /dev/null
+++ b/dev-lang/nelua/nelua-99999999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Statically-typed systems programming language inspired by Lua"
+HOMEPAGE="https://nelua.io/
+ https://github.com/edubart/nelua-lang/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/edubart/nelua-lang.git"
+else
+ SRC_URI="https://github.com/edubart/nelua-lang/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/nelua-lang-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-lua/luacheck
+ )
+"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX="/usr" install
+ einstalldocs
+}