summaryrefslogtreecommitdiff
path: root/dev-lang/oorexx/oorexx-5.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 05:49:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 05:49:55 +0000
commit73e3b099187df1c4f2df056e45f345a56d2535aa (patch)
tree42fef135111a0d9bb70b2843f3d9158875b891b0 /dev-lang/oorexx/oorexx-5.0.0.ebuild
parentb0c85b2635958d1aa7c9cee8dbf22ad871a280f1 (diff)
gentoo auto-resync : 30:01:2024 - 05:49:55
Diffstat (limited to 'dev-lang/oorexx/oorexx-5.0.0.ebuild')
-rw-r--r--dev-lang/oorexx/oorexx-5.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/oorexx/oorexx-5.0.0.ebuild b/dev-lang/oorexx/oorexx-5.0.0.ebuild
new file mode 100644
index 000000000000..51c81bc9f4f2
--- /dev/null
+++ b/dev-lang/oorexx/oorexx-5.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+APP_REVISION=12583
+
+inherit cmake
+
+DESCRIPTION="Open source implementation of Object Rexx"
+HOMEPAGE="https://www.oorexx.org/about.html
+ https://sourceforge.net/projects/oorexx/"
+SRC_URI="https://sourceforge.net/projects/${PN}/files/${PN}/${PV}/${P}-${APP_REVISION}.tar.gz"
+S="${WORKDIR}/${P}"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ virtual/libcrypt:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-5.0.0-man.patch" )
+
+src_unpack() {
+ default
+
+ # HACK: Dance around cmake.eclass S directory requirements.
+ mv "${WORKDIR}" "${T}/${P}" || die
+ mkdir -p "${WORKDIR}" || die
+ mv "${T}/${P}" "${S}" || die
+}