summaryrefslogtreecommitdiff
path: root/dev-lang/open-cobol/open-cobol-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 13:10:40 +0000
commitc92d0cd2b34d17bce6d5bb4e3a4fc00af4193c99 (patch)
tree517559f918260cf91e7bdd4e484aa6fe9085cb9f /dev-lang/open-cobol/open-cobol-1.1.ebuild
parenta59ffccce3bf214fae9932cc42400eeeaec25c6c (diff)
gentoo auto-resync : 24:11:2022 - 13:10:39
Diffstat (limited to 'dev-lang/open-cobol/open-cobol-1.1.ebuild')
-rw-r--r--dev-lang/open-cobol/open-cobol-1.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-lang/open-cobol/open-cobol-1.1.ebuild b/dev-lang/open-cobol/open-cobol-1.1.ebuild
deleted file mode 100644
index d7fd39c417a0..000000000000
--- a/dev-lang/open-cobol/open-cobol-1.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_PN="open-cobol"
-# Future proof pkg if maintainer or p-m want to bump to latest GNUCobol
-
-DESCRIPTION="an open-source COBOL compiler"
-HOMEPAGE="https://sourceforge.net/projects/open-cobol/"
-SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-# License must be changed to GPL-3+ if/when pkgmove is done
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="berkdb nls readline"
-
-RDEPEND="dev-libs/gmp:0=
- berkdb? ( sys-libs/db:4.8= )
- sys-libs/ncurses
- readline? ( sys-libs/readline )"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
-
-src_configure() {
- econf \
- $(use_with berkdb db) \
- $(use_enable nls) \
- $(use_with readline) \
- --disable-static
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-}