summaryrefslogtreecommitdiff
path: root/dev-lang/php
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-05 00:07:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-05 00:07:53 +0100
commit9d1e33edaf09cde926d589461f40e378d4124be9 (patch)
treeb0a5a85acd92ce912a95245121dde9cebcf76b71 /dev-lang/php
parentdafa6f367240d1f5329ca89fb6f78985dbdc025b (diff)
gentoo auto-resync : 05:06:2024 - 00:07:52
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/Manifest2
-rw-r--r--dev-lang/php/php-8.3.7-r1.ebuild (renamed from dev-lang/php/php-8.3.7.ebuild)26
2 files changed, 15 insertions, 13 deletions
diff --git a/dev-lang/php/Manifest b/dev-lang/php/Manifest
index 4c242a71ec26..bdbef38784f1 100644
--- a/dev-lang/php/Manifest
+++ b/dev-lang/php/Manifest
@@ -18,5 +18,5 @@ EBUILD php-8.1.28.ebuild 22549 BLAKE2B d09d8749f4daa08f6aae974f79a0726dca5890058
EBUILD php-8.2.15.ebuild 25370 BLAKE2B 48ace575c7542824739c35e836e7213008d355214c0ad77e358e4e70887aa76a990f0bc4a583097a1cd16c6b37f7da6ca6fe20b419d7ca628838be0f89557d80 SHA512 266d3c538548bd124a828eaa4ab2b9f4daaf954005f589f83fc4b66bb1a6b7a980c2fbf056d8a86fc5c956ea0231fd76deca57861661274c3693b561397c1e1d
EBUILD php-8.2.18.ebuild 25786 BLAKE2B b6c8acb63663a8cc0e4adc7cc79b285e95add4308a5686523d3808b5ac21ed075091cddf17854733fa429ec8ff0210a580352d727358fd281acb7238d18fad44 SHA512 0480657861f695fd3ab011720c7dfdbd59c9fcb297dcf1e72c10877235e2e131c12bfa184268a6602834b9a5502befebd569d4184ba7a3f35166c89e2959fdfd
EBUILD php-8.2.19.ebuild 25960 BLAKE2B 21038b0a2def2da5fbe2efb6faa64e95ed619afdd3a717da1a20bcfe2df3a0a7246650bf203647f22efb5be491c1840e14a11fa7873e7c6d74d51bb07643dee0 SHA512 4cc206554e25576a5fb56b1996247eaa665167bf9d94571185c90033342676f064a627dac87848efad48cb35a98a34c7f3b22e432823b04ababb714ed4a2a1f0
-EBUILD php-8.3.7.ebuild 22685 BLAKE2B 110af78b2d349edfe198a37db51abd3cf7792e4da553ea1b9500944ff0587e7ee2ecb3c94cbc198b8ed45b0158765817bfb6b9cf4a5a5881a092f91a1fa5eedc SHA512 c9dab5d7ceb5f768f3e5ad223a3a550d76672499e9b27e8a359bafe77c9a75bbc7319d243017bac143ee50de788ac5b85443ec6491b6a9f31148ee1c2e235b4b
+EBUILD php-8.3.7-r1.ebuild 23098 BLAKE2B 5408dbb7612ba5c4555b0c646b616dd93897d126121053b136cbcb39cc3a3faba7144a7dc9ccafa1156b840a70b3f6b21ac680669af424bf08a31e879fd7f879 SHA512 b069bc436c08e80a023b92b918304083c75802d85bec97ec4655520c649df553ff1d6e566c8699a01fd955bfc66b1aea544101e7e47921992283007523029878
MISC metadata.xml 4134 BLAKE2B 62c1c5052c50db537586edc1db639fa94e24609ea027208177566ae7f7f9199103bb3ef5b636766508027e8e7aacb8451d25b57e981b582bc42299e199696a68 SHA512 b059c7552c18dfcabe82170c1ae5978421284f3ea9ea9505359c1441ccc76b668a5555919251c6ca55f1f450da9363a8ac7b30c393a8506921f790e0f4197dbb
diff --git a/dev-lang/php/php-8.3.7.ebuild b/dev-lang/php/php-8.3.7-r1.ebuild
index 1ccb66ce8a52..607ae090b3e6 100644
--- a/dev-lang/php/php-8.3.7.ebuild
+++ b/dev-lang/php/php-8.3.7-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
WANT_AUTOMAKE="none"
-inherit flag-o-matic multilib systemd autotools
+inherit flag-o-matic multilib systemd
DESCRIPTION="The PHP language runtime engine"
HOMEPAGE="https://www.php.net/"
@@ -144,10 +144,6 @@ BDEPEND="virtual/pkgconfig"
PHP_MV="$(ver_cut 1)"
-PATCHES=(
- "${FILESDIR}/php-iodbc-header-location.patch"
-)
-
# ARM/Windows functions (bug 923335)
QA_CONFIG_IMPL_DECL_SKIP=(
__crc32d
@@ -228,12 +224,6 @@ src_prepare() {
sapi/fpm/php-fpm.conf.in \
|| die 'failed to move the include directory in php-fpm.conf'
- # Emulate buildconf to support cross-compilation
- rm -fr aclocal.m4 autom4te.cache config.cache \
- configure main/php_config.h.in || die
- eautoconf --force
- eautoheader
-
# fails in a network sandbox,
#
# https://github.com/php/php-src/issues/11662
@@ -418,10 +408,22 @@ src_configure() {
# ODBC support
if use odbc && use iodbc ; then
+ # Obtain the correct -l and -I flags for the actual build from
+ # pkg-config. We use the "generic" library type to avoid the
+ # (wrong) hard-coded include dir for iodbc.
+ #
+ # We set the pdo_odbc_def_incdir variable because the
+ # ./configure script checks for the headers using "test -f" and
+ # ignores your CFLAGS... and pdo_odbc_def_libdir prevents the
+ # build system from appending a nonsense -L flag.
+ local iodbc_ldflags=$(pkg-config --libs libiodbc)
+ local iodbc_cflags=$(pkg-config --cflags libiodbc)
our_conf+=(
+ pdo_odbc_def_libdir="${EPREFIX}/usr/$(get_libdir)"
+ pdo_odbc_def_incdir="${EPREFIX}/usr/include/iodbc"
--without-unixODBC
--with-iodbc
- $(use_with pdo pdo-odbc "iODBC,${EPREFIX}/usr")
+ $(use_with pdo pdo-odbc "generic,,iodbc,${iodbc_ldlags},${iodbc_cflags}")
)
elif use odbc ; then
our_conf+=(