summaryrefslogtreecommitdiff
path: root/dev-lang/rust
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-26 01:13:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-26 01:13:45 +0000
commit7bd77a6744e2cd6d203240181996a998985e0288 (patch)
tree75dc88e47dcab0692b84f1b2684ffa9fde351aff /dev-lang/rust
parentc33b50e5d2446c439465ff4575253db72ef2b8f6 (diff)
gentoo auto-resync : 26:11:2022 - 01:13:45
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/Manifest2
-rw-r--r--dev-lang/rust/rust-1.65.0.ebuild11
2 files changed, 3 insertions, 10 deletions
diff --git a/dev-lang/rust/Manifest b/dev-lang/rust/Manifest
index 11062bba26b6..7206406ad68d 100644
--- a/dev-lang/rust/Manifest
+++ b/dev-lang/rust/Manifest
@@ -71,5 +71,5 @@ DIST rustc-1.64.0-src.tar.xz.asc 801 BLAKE2B 69f7bd7600d99794859c6fad4b44f0e9886
DIST rustc-1.65.0-src.tar.xz 139674928 BLAKE2B a218263fb67e306b153f5a6dae95b5ec653acaa5eb4b833862d6f0fd4685a8cec097dadc1b8a934e1bf6055672c7a617f9a0ad4a7dbf2e78084297f10b7ada04 SHA512 3d0369ed3028209c4ecb9b9e7b5f5e3a20be8cc05199675df4f091d62a96c0734bc1dbd7630928fe162792392ec6d0daf9ceed10771531ce022200c7b631e3be
DIST rustc-1.65.0-src.tar.xz.asc 801 BLAKE2B 43ff92011cd6f7f34ce0495fa341379e5907d032ea90f91e533e5edaec6ad518aad50a9d8b2694074d6909ee96aa779403b16e95792e962e79c1b967542ae26f SHA512 75b9be53363022c81333117876cbcc573bbd4733edf767cbb164218644efb1a9c4bfc2aa73aaa1e39f248a84f1adacb1930a94a6e63f60093ff760fb9ae02efc
EBUILD rust-1.64.0-r1.ebuild 23867 BLAKE2B b9d8aa35b84e668fb038fb813bfc6bc2bae4dce945e381cff0645a1fa9463a8cd30aa92e0018a407263929bd0da169191de136e634c9edacccd1ac0ffb69337b SHA512 4a174b1d34e6f7bfd860629d0bc06e99a7accf9eb7c7bf51f10db8b255237c63b3a5aee1291dd2ceb404676a67f5e507a7414ecc132c5926ee292cc047b0ced4
-EBUILD rust-1.65.0.ebuild 23996 BLAKE2B d7a926797df27b629379e237dff0b2017965a488f4cda8c0e26e3e44d32a5d09511e446fd03a4c6312d609a576955a6a216651babe754b7e14c81b8d3d0da35c SHA512 0c651df80c60ff8dbefcc72fe452088d42d04c98e3d5c51257eb91558962b74209286ec274b1ff0d7b66812fc6406cf13278d349b9a85aa2f851526a3ab87738
+EBUILD rust-1.65.0.ebuild 23814 BLAKE2B 85f3750587026d3447efc5c7c6aacfe083e24408b2c19b1ec665608aabee39b0d1787714fac3f720a2678c3bdcfb2879beeae0260618cb3551125edb3e3f1ac9 SHA512 f02ab726b02167a018f924ed46138036beb87d462508f6fa159050e7d0a78b91e65e7c42e832b298bd511dc1050453b888e05d93eec1fd88c24a77f4ab736bdd
MISC metadata.xml 1770 BLAKE2B d5881dc5ea39a5bfff7c74fa883dc1a6370db572568e10fce81467c2f2a17018de48123dfa7993d6d9644305bfc5ef5b0f445ef40362065fce943efb4af2e761 SHA512 c914e1a0cee95fa5cb332240f3eb6fbee73e5d8baabfa6bdcdc3e852c9480fea0686e435b969e14f45d8c791655edc6e6a7df2259ac99b6a6e63af65b09fa57e
diff --git a/dev-lang/rust/rust-1.65.0.ebuild b/dev-lang/rust/rust-1.65.0.ebuild
index bfc942995c50..2306e80be316 100644
--- a/dev-lang/rust/rust-1.65.0.ebuild
+++ b/dev-lang/rust/rust-1.65.0.ebuild
@@ -41,7 +41,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/(-)?}
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-IUSE="clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rls rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
+IUSE="clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind miri nightly parallel-compiler profiler rustfmt rust-analyzer rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
# Please keep the LLVM dependency block separate. Since LLVM is slotted,
# we need to *really* make sure we're not pulling more than one slot
@@ -126,7 +126,6 @@ RDEPEND="${DEPEND}
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
miri? ( nightly )
parallel-compiler? ( nightly )
- rls? ( rust-src )
rust-analyzer? ( !wasm )
test? ( ${ALL_LLVM_TARGETS[*]} )
wasm? ( llvm_targets_WebAssembly )
@@ -208,7 +207,6 @@ pre_build_checks() {
fi
M=$(( $(usex clippy 128 0) + ${M} ))
M=$(( $(usex miri 128 0) + ${M} ))
- M=$(( $(usex rls 512 0) + ${M} ))
M=$(( $(usex rustfmt 256 0) + ${M} ))
# add 2G if we compile llvm and 256M per llvm_target
if ! use system-llvm; then
@@ -331,9 +329,8 @@ src_configure() {
use clippy && tools+=',"clippy"'
use miri && tools+=',"miri"'
use profiler && tools+=',"rust-demangler"'
- use rls && tools+=',"rls","analysis"'
use rustfmt && tools+=',"rustfmt"'
- use rust-analyzer && tools+=',"rust-analyzer"'
+ use rust-analyzer && tools+=',"rust-analyzer","analysis"'
use rust-src && tools+=',"src"'
local rust_stage0_root
@@ -658,7 +655,6 @@ src_install() {
use clippy && symlinks+=( clippy-driver cargo-clippy )
use miri && symlinks+=( miri cargo-miri )
use profiler && symlinks+=( rust-demangler )
- use rls && symlinks+=( rls )
use rustfmt && symlinks+=( rustfmt cargo-fmt )
use rust-analyzer && symlinks+=( rust-analyzer )
@@ -719,9 +715,6 @@ src_install() {
if use profiler; then
echo /usr/bin/rust-demangler >> "${T}/provider-${P}"
fi
- if use rls; then
- echo /usr/bin/rls >> "${T}/provider-${P}"
- fi
if use rustfmt; then
echo /usr/bin/rustfmt >> "${T}/provider-${P}"
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"