summaryrefslogtreecommitdiff
path: root/dev-lang/vala/vala-0.56.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-20 00:30:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-20 00:30:25 +0000
commit77684468238b8755c1aa3e72f3055f4e62fcf14c (patch)
tree7c18f4b036e2a73cd48b63c5d7c711bc5cf1b989 /dev-lang/vala/vala-0.56.18.ebuild
parent781c9128468d2e8302221d4d7152ae09cffc4a9e (diff)
gentoo auto-resync : 20:03:2025 - 00:30:24HEADnextmaster
Diffstat (limited to 'dev-lang/vala/vala-0.56.18.ebuild')
-rw-r--r--dev-lang/vala/vala-0.56.18.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-lang/vala/vala-0.56.18.ebuild b/dev-lang/vala/vala-0.56.18.ebuild
new file mode 100644
index 000000000000..e0e15eec0845
--- /dev/null
+++ b/dev-lang/vala/vala-0.56.18.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Compiler for the GObject type system"
+HOMEPAGE="https://vala.dev https://gitlab.gnome.org/GNOME/vala"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.56"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="test valadoc"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.48.0:2
+ >=dev-libs/vala-common-${PV}
+ valadoc? ( >=media-gfx/graphviz-2.16 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection
+ test? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26:2
+ )
+"
+BDEPEND="
+ dev-libs/libxslt
+ app-alternatives/lex
+ virtual/pkgconfig
+ app-alternatives/yacc
+"
+
+src_configure() {
+ # weasyprint enables generation of PDF from HTML
+ gnome2_src_configure \
+ --disable-unversioned \
+ $(use_enable valadoc) \
+ VALAC=: \
+ WEASYPRINT=:
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}