summaryrefslogtreecommitdiff
path: root/dev-lang/yap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /dev-lang/yap
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'dev-lang/yap')
-rw-r--r--dev-lang/yap/Manifest1
-rw-r--r--dev-lang/yap/yap-6.3.3-r1.ebuild124
2 files changed, 125 insertions, 0 deletions
diff --git a/dev-lang/yap/Manifest b/dev-lang/yap/Manifest
index 237796812042..708cca58f774 100644
--- a/dev-lang/yap/Manifest
+++ b/dev-lang/yap/Manifest
@@ -1,4 +1,5 @@
DIST yap-6.3.3-gentoo-patchset-11.tar.gz 6021 BLAKE2B d83682de9a6f095482db66f4fd5bb562739121b8502464d92fb784c634bfbfc020ae3ec55641aaeb8c0d52ce5534f7888bdd7d3d556f68c749b2f0ee35860764 SHA512 d9645a6f5c2b633fb5b61f8b6219ac69ae28e4f53f149fcdbb161cb7a8226aecab64f831a19e73876eb5056bb9efc3501fe792b6dca418a2a56b058ec658a2db
DIST yap-6.3.3.tar.gz 7879301 BLAKE2B 1b12a3113dd57634df64680726fd49575979b84126a7a9e1f4d1429be90e1b95599166151ffe62c9ef990ac3c32f57a1efae081b864fc22225c93d21807f412b SHA512 4ef45277ec84b6e072fa54afc7d6c18f11c3a0cdf477e35e35a0ce2181c9ff2e693f8735f63a1899373f6baf79ce0a972b37e1ae6ed8271bec60663f477bbe80
+EBUILD yap-6.3.3-r1.ebuild 2857 BLAKE2B 5412e16a8b26b285aa7698138219650ad8a3ab4ba7d2f384d4e9204930ca2e9b273722a5122df8570f7c24f9cdd595f28945ebb87b952fad23e6463b613bfdff SHA512 408ff3711cf15b5a25a7e9115c884cc13c6b79053345fc1b769fde00a26e0ee1877ef9368b35100af354a17b863073efe54c793b4e36ca49d4341e251867a7f8
EBUILD yap-6.3.3.ebuild 2869 BLAKE2B 755423834f09ec5d57b0e568a3fbc8c3639eacf8ac3db2d3048a73685af7c7cc3b8caf0628d31436e9045e6828c21de18f984662ee94eec1ee4bc586579e885b SHA512 68d0234ff375d36bd8b90c2b3375285684146f1b61b16c1a2ae7ba4a0e957f197cb357634be75395dd11f8ef43f6526e0300e0ed53da800faccc1688f32bbd23
MISC metadata.xml 314 BLAKE2B af1c9bedbf26431e7a624c520a4c93ca9eff16f2539741b01ccf5da16c710c82d3820e3ad647a36a4629dc7b316a18c1b1306314200843e1d4d6b95c8c829442 SHA512 c5bd279aec3b80e6c08dfaa85cf091cbfcbf9380f1e5a8a0fcd6f27297368b92906340ae9dfd5176f37d36e4fb61ca772448c0248121d8e302c181bf670e57bc
diff --git a/dev-lang/yap/yap-6.3.3-r1.ebuild b/dev-lang/yap/yap-6.3.3-r1.ebuild
new file mode 100644
index 000000000000..fd653ef29268
--- /dev/null
+++ b/dev-lang/yap/yap-6.3.3-r1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic java-pkg-opt-2
+
+PATCHSET_VER="11"
+
+DESCRIPTION="YAP is a high-performance Prolog compiler"
+HOMEPAGE="http://www.dcc.fc.up.pt/~vsc/Yap/"
+SRC_URI="http://www.dcc.fc.up.pt/~vsc/Yap/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="R debug doc examples gmp java mpi mysql odbc readline static threads"
+
+RDEPEND="sys-libs/zlib
+ gmp? ( dev-libs/gmp:0 )
+ java? ( >=virtual/jdk-1.4:= )
+ mpi? ( virtual/mpi )
+ mysql? ( dev-db/mysql-connector-c:0= )
+ odbc? ( dev-db/unixODBC )
+ readline? ( sys-libs/readline:= sys-libs/ncurses:= )
+ R? ( dev-lang/R )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-text/texi2html )"
+
+PATCHES=( "${WORKDIR}"/${PV} )
+
+src_prepare() {
+ default
+ rm -rf "${S}"/yap || die "failed to remove yap xcode project"
+
+ # Fix QA error on doc location
+ local mFile
+ for mFile in Makefile.in packages/Dialect.defs.in \
+ $(find packages -name Makefile.in) ; do
+ sed -i -e "s~doc/Yap~doc/${PF}~" "${mFile}" || die
+ done
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ local myddas_conf
+ if use mysql || use odbc; then
+ myddas_conf="--enable-myddas"
+ else
+ myddas_conf="--disable-myddas"
+ fi
+ if use mysql; then
+ myddas_conf="$myddas_conf yap_with_mysql=yes"
+ fi
+ if use odbc; then
+ myddas_conf="$myddas_conf yap_with_odbc=yes"
+ fi
+
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --disable-prism \
+ --disable-gecode \
+ $(use_enable !static dynamic-loading) \
+ $(use_enable threads) \
+ $(use_enable threads pthread-locking) \
+ $(use_enable debug debug-yap) \
+ $(use_enable debug low-level-tracer) \
+ $(use_with gmp) \
+ $(use_with readline) \
+ $(use_with mpi) \
+ $(use_with mpi mpe) \
+ $(use_with java) \
+ $(use_with R) \
+ ${myddas_conf}
+}
+
+src_compile() {
+ default
+
+ if use doc ; then
+ emake html
+ fi
+}
+
+src_test() {
+ # libtai package contains check.c which confuses the default
+ # src_test() function
+ true
+}
+
+src_install() {
+ default
+
+ dodoc changes*.html README
+
+ if use doc ; then
+ dodoc yap.html
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples/chr
+ doins packages/chr/Examples/*
+ insinto /usr/share/doc/${PF}/examples/clib
+ doins packages/clib/demo/*
+ insinto /usr/share/doc/${PF}/examples/http
+ doins -r packages/http/examples/*
+ insinto /usr/share/doc/${PF}/examples/plunit
+ doins packages/plunit/examples/*
+ if use java ; then
+ insinto /usr/share/doc/${PF}/examples/jpl/prolog
+ doins packages/jpl/examples/prolog/*
+ insinto /usr/share/doc/${PF}/examples/jpl/java
+ doins packages/jpl/examples/java/README
+ doins -r packages/jpl/examples/java/*/*.{java,pl}
+ fi
+ if use mpi ; then
+ insinto /usr/share/doc/${PF}/examples/mpi
+ doins library/mpi/examples/*.pl
+ fi
+ fi
+}