summaryrefslogtreecommitdiff
path: root/dev-lang
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-21 22:50:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-21 22:50:10 +0000
commitb6e823198d27bc8b1abf6ad0956f3b33ff1d35a0 (patch)
tree372d772f8bb2aa14c207514eca339cd413ca076f /dev-lang
parenta20d6a70837f7859762be1d1c9d13e1a20212320 (diff)
gentoo auto-resync : 21:01:2024 - 22:50:10
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/Manifest.gzbin21328 -> 21493 bytes
-rw-r--r--dev-lang/kotlin-bin/Manifest3
-rw-r--r--dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild59
-rw-r--r--dev-lang/kotlin-bin/metadata.xml19
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-lang/Manifest.gz b/dev-lang/Manifest.gz
index 05d0cea2eb40..bec44c8c7367 100644
--- a/dev-lang/Manifest.gz
+++ b/dev-lang/Manifest.gz
Binary files differ
diff --git a/dev-lang/kotlin-bin/Manifest b/dev-lang/kotlin-bin/Manifest
new file mode 100644
index 000000000000..d2ced1fcedc0
--- /dev/null
+++ b/dev-lang/kotlin-bin/Manifest
@@ -0,0 +1,3 @@
+DIST kotlin-compiler-1.9.22.zip 91026092 BLAKE2B 2fc776b27e30a9d75640dc8fc004bfec5207b1b79c2742aa6a8a75971a8b41310cc16712d6d0921e1fa7545031a75ca8256c48f5c1e13f4e36d82df2574d5699 SHA512 d0e1bdfb1918f007444b1cef6e0c29c2c1846819edd60d016ed62327ea6d2cb505aa18658f916f88b91d9fbdfe0b155ad3361728d6a7a9062806d982bc9b8c6c
+EBUILD kotlin-bin-1.9.22.ebuild 1005 BLAKE2B 0c2efbc96602feaa82e87463c19ab244d44bd7b9596177346ae08331d37a53e1f033f41cc0ee557e7b806997a1d553b8e33eb8abd69bd8552db316053276d21f SHA512 c96c829a4c8f21ed7a82de4af30756806d27f72394242115a1cc34fa755f93f1d1cd7a42abfc6bb40ab3c4209ea6428464ccc9a32aadb16e077f132194abb085
+MISC metadata.xml 696 BLAKE2B 5ff5c3681ab7e083f1a2ea607b183c279c50a022eea2237bfc705d67b8e3ddac7d61fdb1774ac2d6214e03d61d0fb03367cd399734a4b537dcf53a3d8cb14de1 SHA512 44186263fa0709e3d4fadd54cc80e1063d215f908855be9476062259387ec9d968f35bfe8da6fbc716be22a53212630676157fd08fbebd67c20dc4a4485b5a44
diff --git a/dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild b/dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild
new file mode 100644
index 000000000000..7e3629cfadfc
--- /dev/null
+++ b/dev-lang/kotlin-bin/kotlin-bin-1.9.22.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-pkg-2 wrapper
+
+DESCRIPTION="Statically typed language that targets the JVM and JavaScript"
+HOMEPAGE="https://kotlinlang.org/
+ https://github.com/JetBrains/kotlin/"
+SRC_URI="https://github.com/JetBrains/kotlin/releases/download/v${PV}/kotlin-compiler-${PV}.zip"
+S="${WORKDIR}/kotlinc"
+
+LICENSE="Apache-2.0 BSD MIT NPL-1.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+DEPEND="
+ >=virtual/jdk-1.8:*
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+src_prepare() {
+ default
+
+ rm bin/*.bat || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ java-pkg_dojar lib/*
+
+ # Follow the Java eclass JAR installation path.
+ local app_home="/usr/share/${PN}"
+
+ exeinto "${app_home}/bin"
+ doexe bin/*
+
+ local -a exes=(
+ kapt
+ kotlin
+ kotlinc
+ kotlinc-js
+ kotlinc-jvm
+ kotlin-dce-js
+ )
+ local exe
+ for exe in "${exes[@]}" ; do
+ make_wrapper "${exe}" "${app_home}/bin/${exe}"
+ done
+}
diff --git a/dev-lang/kotlin-bin/metadata.xml b/dev-lang/kotlin-bin/metadata.xml
new file mode 100644
index 000000000000..96b80b4a00c2
--- /dev/null
+++ b/dev-lang/kotlin-bin/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Kotlin is a statically typed language that targets the JVM and JavaScript.
+ It is a general-purpose language intended for industry use. It is developed
+ by a team at JetBrains although it is an OSS language and has external
+ contributors.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/JetBrains/kotlin/issues/</bugs-to>
+ <remote-id type="github">JetBrains/kotlin</remote-id>
+ </upstream>
+</pkgmetadata>