summaryrefslogtreecommitdiff
path: root/dev-libs/FBGEMM/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-24 11:40:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-24 11:40:42 +0000
commita625efe29cec7f7c437cf33a956ea99eed1e4bd9 (patch)
tree3132969a9e093b34d3bd91ee6110a1111a965630 /dev-libs/FBGEMM/files
parent1ff514162358897632ab329134c6bc75af618f10 (diff)
gentoo auto-resync : 24:02:2024 - 11:40:42
Diffstat (limited to 'dev-libs/FBGEMM/files')
-rw-r--r--dev-libs/FBGEMM/files/FBGEMM-2022.01.13-gentoo.patch65
-rw-r--r--dev-libs/FBGEMM/files/FBGEMM-2022.07.16-gcc13.patch10
2 files changed, 0 insertions, 75 deletions
diff --git a/dev-libs/FBGEMM/files/FBGEMM-2022.01.13-gentoo.patch b/dev-libs/FBGEMM/files/FBGEMM-2022.01.13-gentoo.patch
deleted file mode 100644
index 9ff87d5b6cb4..000000000000
--- a/dev-libs/FBGEMM/files/FBGEMM-2022.01.13-gentoo.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- a/CMakeLists.txt 2022-05-21 13:13:50.806813151 +0200
-+++ b/CMakeLists.txt 2022-05-21 13:16:46.448969453 +0200
-@@ -187,7 +187,7 @@
- message(WARNING "CMAKE_CXX_FLAGS_RELEASE is ${CMAKE_CXX_FLAGS_RELEASE}")
- message(WARNING "==========")
-
--if(NOT TARGET asmjit)
-+if(FALSE)
- #Download asmjit from github if ASMJIT_SRC_DIR is not specified.
- if(NOT DEFINED ASMJIT_SRC_DIR)
- set(ASMJIT_SRC_DIR "${FBGEMM_SOURCE_DIR}/third_party/asmjit"
-@@ -216,7 +216,7 @@
- endif()
- endif()
-
--if(NOT TARGET cpuinfo)
-+if(FALSE)
- #Download cpuinfo from github if CPUINFO_SOURCE_DIR is not specified.
- if(NOT DEFINED CPUINFO_SOURCE_DIR)
- set(CPUINFO_SOURCE_DIR "${FBGEMM_SOURCE_DIR}/third_party/cpuinfo"
-@@ -293,7 +293,6 @@
-
- target_link_libraries(fbgemm $<BUILD_INTERFACE:asmjit>
- $<BUILD_INTERFACE:cpuinfo>)
--add_dependencies(fbgemm asmjit cpuinfo)
-
- install(TARGETS fbgemm EXPORT fbgemmLibraryConfig
- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
-@@ -302,6 +301,8 @@
-
- install(FILES ${FBGEMM_PUBLIC_HEADERS}
- DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/fbgemm")
-+install(FILES src/RefImplementations.h
-+ DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/fbgemm/src")
-
- install(EXPORT fbgemmLibraryConfig DESTINATION share/cmake/fbgemm
- FILE fbgemmLibraryConfig.cmake)
---- a/test/CMakeLists.txt 2022-05-21 13:15:34.140135199 +0200
-+++ b/test/CMakeLists.txt 2022-05-21 13:17:59.170813431 +0200
-@@ -1,6 +1,6 @@
- cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
-
--if(FBGEMM_BUILD_TESTS AND NOT TARGET gtest)
-+if(FALSE)
- #Download Googletest framework from github if
- #GOOGLETEST_SOURCE_DIR is not specified.
- if(NOT DEFINED GOOGLETEST_SOURCE_DIR)
-@@ -67,7 +67,6 @@
- target_link_libraries(${TESTNAME} ${OpenMP_CXX_LIBRARIES})
- endif()
-
-- add_dependencies(${TESTNAME} gtest fbgemm)
- add_test(${TESTNAME} ${TESTNAME})
- set_target_properties(${TESTNAME} PROPERTIES FOLDER test)
- endmacro()
---- a/src/PackMatrix.cc 2022-05-24 08:19:00.639462626 +0200
-+++ b/src/PackMatrix.cc 2022-05-24 08:27:59.127720548 +0200
-@@ -30,6 +30,7 @@
- }
-
- template <typename PT, typename inpType, typename accType>
-+FBGEMM_API
- int PackMatrix<PT, inpType, accType>::packedBufferSize(
- int rows,
- int cols,
diff --git a/dev-libs/FBGEMM/files/FBGEMM-2022.07.16-gcc13.patch b/dev-libs/FBGEMM/files/FBGEMM-2022.07.16-gcc13.patch
deleted file mode 100644
index cba259688d96..000000000000
--- a/dev-libs/FBGEMM/files/FBGEMM-2022.07.16-gcc13.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/include/fbgemm/UtilsAvx2.h 2023-03-11 17:17:28.365325199 +0100
-+++ b/include/fbgemm/UtilsAvx2.h 2023-03-11 17:18:06.076766162 +0100
-@@ -9,6 +9,7 @@
- // flags.
-
- #include <string>
-+#include <cstdint>
-
- namespace fbgemm {
-