summaryrefslogtreecommitdiff
path: root/dev-libs/Ice/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-libs/Ice/files
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-libs/Ice/files')
-rw-r--r--dev-libs/Ice/files/Ice-3.6.3-csharp.patch50
-rw-r--r--dev-libs/Ice/files/Ice-3.6.3-libressl.patch164
-rw-r--r--dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch50
3 files changed, 264 insertions, 0 deletions
diff --git a/dev-libs/Ice/files/Ice-3.6.3-csharp.patch b/dev-libs/Ice/files/Ice-3.6.3-csharp.patch
new file mode 100644
index 000000000000..e9dce1146baa
--- /dev/null
+++ b/dev-libs/Ice/files/Ice-3.6.3-csharp.patch
@@ -0,0 +1,50 @@
+--- ice-3.6.3/csharp/src/Makefile~ 2015-06-23 17:30:20.000000000 +0200
++++ ice-3.6.3/csharp/src/Makefile 2015-06-27 20:07:04.217188211 +0200
+@@ -11,7 +11,7 @@
+
+ include $(top_srcdir)/config/Make.rules.cs
+
+-SUBDIRS = Ice IceStorm Glacier2 IcePatch2 IceGrid IceBox IceDiscovery IceLocatorDiscovery
++SUBDIRS = Ice IceStorm Glacier2 IcePatch2 IceGrid IceBox IceSSL IceDiscovery IceLocatorDiscovery
+
+ $(EVERYTHING)::
+ @for subdir in $(SUBDIRS); \
+--- /dev/null 2015-06-27 16:44:15.733558105 +0200
++++ ice-3.6.3/csharp/lib/pkgconfig/IceSSL.pc 2015-06-27 20:19:30.731894653 +0200
+@@ -0,0 +1,10 @@
++version = 3.6.3
++mono_root = /usr
++
++name = IceSSL
++
++Name: ${name}
++Description: IceSSL run-time support
++Version: ${version}
++Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
++Requires: Ice = ${version}
+--- /dev/null 2015-06-27 16:44:15.733558105 +0200
++++ ice-3.6.3/csharp/lib/pkgconfig/IceDiscovery.pc 2015-06-27 20:20:44.312515987 +0200
+@@ -0,0 +1,10 @@
++version = 3.6.3
++mono_root = /usr
++
++name = IceDiscovery
++
++Name: ${name}
++Description: IceDiscovery run-time support
++Version: ${version}
++Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
++Requires: Ice = ${version}
+--- /dev/null 2015-06-27 16:44:15.733558105 +0200
++++ ice-3.6.3/csharp/lib/pkgconfig/IceLocatorDiscovery.pc 2015-06-27 20:21:22.206185123 +0200
+@@ -0,0 +1,10 @@
++version = 3.6.3
++mono_root = /usr
++
++name = IceLocatorDiscovery
++
++Name: ${name}
++Description: IceLocatorDiscovery run-time support
++Version: ${version}
++Libs: -r:${mono_root}/lib/mono/${name}/${name}.dll
++Requires: Ice = ${version}
diff --git a/dev-libs/Ice/files/Ice-3.6.3-libressl.patch b/dev-libs/Ice/files/Ice-3.6.3-libressl.patch
new file mode 100644
index 000000000000..e7d42e3f0d0c
--- /dev/null
+++ b/dev-libs/Ice/files/Ice-3.6.3-libressl.patch
@@ -0,0 +1,164 @@
+From cbbac2c31a04e956261489ce75c962be7e2454ae Mon Sep 17 00:00:00 2001
+From: Joe George <joe@zeroc.com>
+Date: Mon, 12 Dec 2016 11:51:41 -0500
+Subject: [PATCH] ICE-7445 - Add libressl build support
+
+---
+ cpp/src/IceSSL/OpenSSLEngine.cpp | 20 ++++++++++----------
+ cpp/src/IceSSL/OpenSSLTransceiverI.cpp | 6 +++---
+ cpp/src/IceSSL/Util.cpp | 8 ++++----
+ 3 files changed, 17 insertions(+), 17 deletions(-)
+
+diff --git a/cpp/src/IceSSL/OpenSSLEngine.cpp b/cpp/src/IceSSL/OpenSSLEngine.cpp
+index 8c45950..7360d06 100644
+--- a/cpp/src/IceSSL/OpenSSLEngine.cpp
++++ b/cpp/src/IceSSL/OpenSSLEngine.cpp
+@@ -43,7 +43,7 @@ IceUtil::Mutex* staticMutex = 0;
+ int instanceCount = 0;
+ bool initOpenSSL = false;
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ IceUtil::Mutex* locks = 0;
+ #endif
+
+@@ -59,10 +59,10 @@ class Init
+ ~Init()
+ {
+ //
+- // OpenSSL 1.1.0 introduces a new thread API and removes
++ // OpenSSL 1.1.0 introduces a new thread API and removes
+ // the need to use a custom thread callback.
+ //
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ CRYPTO_set_locking_callback(0);
+ CRYPTO_set_id_callback(0);
+
+@@ -84,10 +84,10 @@ extern "C"
+ {
+
+ //
+-// OpenSSL 1.1.0 introduces a new thread API and removes
++// OpenSSL 1.1.0 introduces a new thread API and removes
+ // the need to use a custom thread callback.
+ //
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ //
+ // OpenSSL mutex callback.
+ //
+@@ -158,7 +158,7 @@ IceSSL_opensslPasswordCallback(char* buf, int size, int flag, void* userData)
+ DH*
+ IceSSL_opensslDHCallback(SSL* ssl, int /*isExport*/, int keyLength)
+ {
+-# if OPENSSL_VERSION_NUMBER >= 0x10100000L
++# if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ SSL_CTX* ctx = SSL_get_SSL_CTX(ssl);
+ # else
+ SSL_CTX* ctx = ssl->ctx;
+@@ -219,7 +219,7 @@ OpenSSLEngine::OpenSSLEngine(const CommunicatorPtr& communicator) :
+ //
+ // OpenSSL 1.1.0 remove the need for library initialization and cleanup.
+ //
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ //
+ // Create the mutexes and set the callbacks.
+ //
+@@ -326,7 +326,7 @@ OpenSSLEngine::~OpenSSLEngine()
+ //
+ // OpenSSL 1.1.0 remove the need for library initialization and cleanup.
+ //
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ //
+ // Clean up OpenSSL resources.
+ //
+@@ -399,7 +399,7 @@ OpenSSLEngine::initialize()
+ "IceSSL: unable to create SSL context:\n" + sslErrors());
+ }
+
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ int securityLevel = properties->getPropertyAsIntWithDefault(propPrefix + "SecurityLevel", -1);
+ if(securityLevel != -1)
+ {
+@@ -954,7 +954,7 @@ OpenSSLEngine::parseProtocols(const StringSeq& protocols) const
+ SSL_METHOD*
+ OpenSSLEngine::getMethod(int /*protocols*/)
+ {
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ SSL_METHOD* meth = const_cast<SSL_METHOD*>(TLS_method());
+ #else
+ //
+diff --git a/cpp/src/IceSSL/OpenSSLTransceiverI.cpp b/cpp/src/IceSSL/OpenSSLTransceiverI.cpp
+index d66c5eb..9f07044 100644
+--- a/cpp/src/IceSSL/OpenSSLTransceiverI.cpp
++++ b/cpp/src/IceSSL/OpenSSLTransceiverI.cpp
+@@ -36,7 +36,7 @@ using namespace IceSSL;
+ //
+ // See: http://cvs.openssl.org/chngview?cn=22569
+ //
+-#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x100000bfL
++#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x100000bfL && !defined(LIBRESSL_VERSION_NUMBER)
+ namespace
+ {
+
+@@ -156,13 +156,13 @@ IceSSL::TransceiverI::initialize(IceInternal::Buffer& readBuffer, IceInternal::B
+ //
+ // See: http://cvs.openssl.org/chngview?cn=22569
+ //
+-#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x100000bfL
++#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x100000bfL && !defined(LIBRESSL_VERSION_NUMBER)
+ IceUtilInternal::MutexPtrLock<IceUtil::Mutex> sync(sslMutex);
+ #endif
+
+ int ret = _incoming ? SSL_accept(_ssl) : SSL_connect(_ssl);
+
+-#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x100000bfL
++#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x100000bfL && !defined(LIBRESSL_VERSION_NUMBER)
+ sync.release();
+ #endif
+ if(ret <= 0)
+diff --git a/cpp/src/IceSSL/Util.cpp b/cpp/src/IceSSL/Util.cpp
+index a60ee4c..50c47f3 100644
+--- a/cpp/src/IceSSL/Util.cpp
++++ b/cpp/src/IceSSL/Util.cpp
+@@ -110,7 +110,7 @@ namespace
+ {
+
+ # ifndef OPENSSL_NO_DH
+-# if OPENSSL_VERSION_NUMBER < 0x10100000L
++# if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+
+ // The following arrays are predefined Diffie Hellman group parameters.
+ // These are known strong primes, distributed with the OpenSSL library
+@@ -228,7 +228,7 @@ unsigned char dh4096_g[] = { 0x02 };
+ //
+ // With OpenSSL 1.1.0 is no longer possible to acess the DH p and g
+ // data members to set the DH params. We still use the same default
+-// parameters but they were converted to DER format using
++// parameters but they were converted to DER format using
+ // i2d_DHparams and can be restored using d2i_DHparams
+
+ unsigned char dh512[] =
+@@ -338,7 +338,7 @@ unsigned char dh4096[] =
+ //
+ // Convert a predefined parameter set into a DH value.
+ //
+-# if OPENSSL_VERSION_NUMBER >= 0x10100000L
++# if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ static DH*
+ convertDH(const unsigned char* buf, int len)
+ {
+@@ -428,7 +428,7 @@ IceSSL::DHParams::get(int keyLength)
+ // No match found. Use one of the predefined parameter sets instead.
+ //
+ IceUtil::Mutex::Lock sync(*this);
+-# if OPENSSL_VERSION_NUMBER >= 0x10100000L
++# if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ if(keyLength >= 4096)
+ {
+ if(!_dh4096)
diff --git a/dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch b/dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch
new file mode 100644
index 000000000000..149a31e1dd6c
--- /dev/null
+++ b/dev-libs/Ice/files/Ice-3.6.3-no-arch-opts.patch
@@ -0,0 +1,50 @@
+--- ice-3.6.3/cpp/config/Make.rules.Linux~ 2015-06-27 16:56:56.000000000 +0200
++++ ice-3.6.3/cpp/config/Make.rules.Linux 2015-06-27 17:23:45.810591931 +0200
+@@ -79,19 +79,6 @@
+ CXXARCHFLAGS += -mtune=v8 -pipe -Wno-deprecated -DICE_USE_MUTEX_SHARED
+ endif
+
+- #
+- # Only use multilib -m32/-m64 options for amd64 arch, x32 arch can also run
+- # in amd64 macines but doesn't use multilib, in this case MACHINE_TYPE will
+- # be x86_64 and HOST_ARCH x32.
+- #
+- ifeq ($(HOST_ARCH),amd64)
+- ifeq ($(LP64),yes)
+- CXXARCHFLAGS += -m64
+- else
+- CXXARCHFLAGS += -m32
+- endif
+- endif
+-
+ CXXFLAGS += $(CXXARCHFLAGS) -fvisibility=hidden -Wall -Werror -pthread
+
+ # If MAXWARN is set then enable extra warnings
+--- ice-3.6.3/config/Make.common.rules~ 2015-06-23 17:30:20.000000000 +0200
++++ ice-3.6.3/config/Make.common.rules 2015-06-28 01:53:57.149666595 +0200
+@@ -101,25 +101,7 @@
+ ifeq ($(LP64),)
+ LP64 = yes
+ endif
+-
+- #
+- # x86 binaries build on x86_64 machine use 32 binsuffix
+- #
+- ifneq ($(STATICLIBS),yes)
+- ifneq ($(LP64),yes)
+- binsuffix = 32
+- endif
+- endif
+ endif
+-
+- #
+- # x86 builds uses 32 binsuffix
+- #
+- ifneq ($(STATICLIBS),yes)
+- ifeq ($(findstring $(MACHINE_TYPE),i386 i486 i586 i686),$(MACHINE_TYPE))
+- binsuffix = 32
+- endif
+- endif
+ endif
+
+ ifeq ($(CPP11),yes)