summaryrefslogtreecommitdiff
path: root/dev-libs/appstream-glib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-libs/appstream-glib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-libs/appstream-glib')
-rw-r--r--dev-libs/appstream-glib/Manifest5
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.6.13.ebuild61
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.7.9.ebuild65
-rw-r--r--dev-libs/appstream-glib/metadata.xml11
4 files changed, 142 insertions, 0 deletions
diff --git a/dev-libs/appstream-glib/Manifest b/dev-libs/appstream-glib/Manifest
new file mode 100644
index 000000000000..a886143423ec
--- /dev/null
+++ b/dev-libs/appstream-glib/Manifest
@@ -0,0 +1,5 @@
+DIST appstream-glib-0.6.13.tar.xz 1974864 BLAKE2B e9e0967b7657250659b3597bc2f6b049a20750e6dc66ee3672f3794b8c50f5060e48c7d4cd76d16e9e7d7cbc7d3364b7600e1c20fe24b33538c66d2a80cf0888 SHA512 d7e95a31d3f6fba974af2fab423282c7b0291d1325a634d8040fe2c2c2fcde49981be18900415251b3d71f20bb9e945e16d7c00fa830b27deac2e5547ec4c8b0
+DIST appstream-glib-0.7.9.tar.xz 2245728 BLAKE2B fb6f54329bed91f1acaa6218b111fd4527dff7ed412a89cb44a6e4f6cdfb7e0fe4e6f9fb37b6cdc2efa75164dccef323b6d7428a63b08369b941d36b0b9071f0 SHA512 d78cb6f11cad01d67cb33f16e987485177d20b78a8b21cfbabb64ce7b18b813c0d2d1de2faeea199fdc31d12633e899a5596a6cf133cb831a4377d641f79eb7d
+EBUILD appstream-glib-0.6.13.ebuild 1606 BLAKE2B af414cb338d410c75c55d94bcdfd1cc43d1c91de1fa503841ef1e5593b1b9269462a64faca6eeac0aaa93e77ec652af0de7f999482ee8420bed3b592fbb0475f SHA512 bc547565c79d072fefac5be7855f4cd00495495bf581c0e9ba57dd830746d137a1ad28eb5d9ed8e60cbcfb8b00d70158436835b5bbe2d7bcba253943ac8449ee
+EBUILD appstream-glib-0.7.9.ebuild 1517 BLAKE2B a3dea107a54200b19c154210e1957fd487453f6c31bad7960177b9d844697489f9b2563f1380b092a3fd3058731727ac16c56a91986ce4fa269fc5154d497089 SHA512 8ff93c762d932ac4df398e336ca1a6e74b3483674b1e47c442726a25747cc2a45460ed8d46c2020c01b256b60038e10e8e56c61fe18f7c3e3c4d81e74a5aade2
+MISC metadata.xml 352 BLAKE2B 2d04b5c85e8a4e5a62ddf862b7dc1d757896d4f7a5aa052b9139cb050d16aedf9b571b543484b91d3795a979703b4bebb6c42695f8238939a4179a613110053f SHA512 491790151594360b57d05b217381b3b6c6f3d3a72e8066d923230060a4b05d0e2ff1e31cdcb94eb8b1ac077a011d695f33b857bf049c04292a9e324c065895d9
diff --git a/dev-libs/appstream-glib/appstream-glib-0.6.13.ebuild b/dev-libs/appstream-glib/appstream-glib-0.6.13.ebuild
new file mode 100644
index 000000000000..ca763db967b6
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.6.13.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit bash-completion-r1 gnome2
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8" # soname version
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 sparc x86"
+IUSE="+introspection nls stemmer"
+
+RDEPEND="
+ app-arch/gcab
+ app-arch/libarchive
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.45.8:2
+ >=dev-libs/json-glib-1.1.1
+ dev-libs/libyaml
+ >=media-libs/fontconfig-2.11:1.0
+ >=media-libs/freetype-2.4:2
+ >=net-libs/libsoup-2.51.92:2.4
+ sys-apps/util-linux
+ >=x11-libs/gdk-pixbuf-2.31.5:2[introspection?]
+ x11-libs/gtk+:3
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+ stemmer? ( dev-libs/snowball-stemmer )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.9
+ >=sys-devel/gettext-0.19.7
+ dev-util/gperf
+"
+# ${PN} superseeds appdata-tools, require dummy package until all ebuilds
+# are migrated to appstream-glib
+RDEPEND="${RDEPEND}
+ !<dev-util/appdata-tools-0.1.8-r1
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-builder \
+ --enable-firmware \
+ --enable-fonts \
+ --disable-rpm \
+ --disable-static \
+ --enable-dep11 \
+ --enable-man \
+ $(use_enable nls) \
+ $(use_enable introspection) \
+ $(use_enable stemmer) \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}
diff --git a/dev-libs/appstream-glib/appstream-glib-0.7.9.ebuild b/dev-libs/appstream-glib/appstream-glib-0.7.9.ebuild
new file mode 100644
index 000000000000..1436a94fb8e2
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.7.9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit xdg meson
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc +introspection stemmer"
+
+RDEPEND="
+ >=dev-libs/glib-2.45.8:2
+ sys-apps/util-linux
+ app-arch/libarchive
+ >=net-libs/libsoup-2.51.92:2.4
+ >=dev-libs/json-glib-1.1.2
+ >=x11-libs/gdk-pixbuf-2.31.5:2[introspection?]
+ app-arch/gcab
+
+ x11-libs/gtk+:3
+ >=media-libs/freetype-2.4:2
+ >=media-libs/fontconfig-2.11:1.0
+ dev-libs/libyaml
+ stemmer? ( dev-libs/snowball-stemmer )
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+"
+# libxml2 required for glib-compile-resources
+DEPEND="${RDEPEND}
+ dev-util/gperf
+
+ dev-libs/libxml2:2
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ doc? (
+ >=dev-util/gtk-doc-1.9
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.7
+"
+# ${PN} superseeds appdata-tools
+RDEPEND="${RDEPEND}
+ !<dev-util/appdata-tools-0.1.8-r1
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddep11=true
+ -Dbuilder=true
+ -Drpm=false
+ -Dalpm=false
+ -Dfonts=true
+ $(meson_use stemmer)
+ -Dman=true
+ $(meson_use doc gtk-doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
diff --git a/dev-libs/appstream-glib/metadata.xml b/dev-libs/appstream-glib/metadata.xml
new file mode 100644
index 000000000000..03dc146005b4
--- /dev/null
+++ b/dev-libs/appstream-glib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<use>
+ <flag name="stemmer">Add word stemming via <pkg>dev-libs/snowball-stemmer</pkg>.</flag>
+</use>
+</pkgmetadata>