summaryrefslogtreecommitdiff
path: root/dev-libs/apr-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
commit171a011ad3a131671aeb5a98b9e3adf219ad2865 (patch)
tree0c877a3d1a37f10e37ad7168cfc52054aa0948a7 /dev-libs/apr-util
parent75fc75ae1f0481ffdb78450e801a9b443ba641bd (diff)
gentoo resync : 02.04.2018
Diffstat (limited to 'dev-libs/apr-util')
-rw-r--r--dev-libs/apr-util/Manifest1
-rw-r--r--dev-libs/apr-util/apr-util-1.6.1-r1.ebuild135
2 files changed, 136 insertions, 0 deletions
diff --git a/dev-libs/apr-util/Manifest b/dev-libs/apr-util/Manifest
index ebdf34eed360..bc26f83aabe7 100644
--- a/dev-libs/apr-util/Manifest
+++ b/dev-libs/apr-util/Manifest
@@ -3,5 +3,6 @@ DIST apr-util-1.5.4.tar.bz2 694427 BLAKE2B 6de337fa48f0ca3775ba5b054b3a59726e25a
DIST apr-util-1.6.1.tar.bz2 428595 BLAKE2B ab6eaf1594aaa1c7aae151319b630b83bdb8b68ec04f0e2b429b7c7789bdf274873270200ba43701359e2502d2be8624d8e42a56a5f399ec95a841e7c73ce706 SHA512 40eff8a37c0634f7fdddd6ca5e596b38de15fd10767a34c30bbe49c632816e8f3e1e230678034f578dd5816a94f246fb5dfdf48d644829af13bf28de3225205d
EBUILD apr-util-1.5.4-r3.ebuild 3696 BLAKE2B 740a3c17f34c719f7b3d977a6866eb45061504d31c93d5fc59189bb3161ef8dd9b641308e17999789f6c547c4a56ce765fb4cbff8052d6e48f5e54ad279708b4 SHA512 024b8b03d382a0e50f6eac0a6e48d72b5e0852d60824df671e5f7b793c06f323b89037507eb131d05b785c3c03bb42862f133f054d89720dee25ab5b67d2f432
EBUILD apr-util-1.5.4.ebuild 3226 BLAKE2B af898360f8c4bf407d32c728b947e81caa11fad30ed3c7ee78e8c376a53b404708bd2f9b66b21d206e4628ff697aa2302ae51e56c5b591995aeafee9f4cf1316 SHA512 0240c037252088a9c1317b4092384730b041ff024e456a2f7c86860545447510be4614e97bf9845d4ef93a251aed346f4700159310611af08f67b74248bf45e6
+EBUILD apr-util-1.6.1-r1.ebuild 3603 BLAKE2B 0fc6012bf57e8ad9eb2f64ec9b00572d85da07889094a2eee7b93d79050153bd0f0dbef6c90591d1425e459c1489cf87b87f9415f1e41baa4e4f6e67443bbb28 SHA512 fdbffe248164f9f5a4cf7949058db79195e3883f05f639e4ea42d5eeefcf640263a75e1010db03bfc56e028b11366929958024b3e74b1ee4071b1892567be042
EBUILD apr-util-1.6.1.ebuild 3602 BLAKE2B 429e1d93762ee3c4ed62b32acd739972f5e389201a63692e2eaa10e62d708c57a595369ed066b65269bad86a5e188ab5e4ad1e57dfc8250c1c019ef734c34a44 SHA512 6045a8af31e1fe8cdbf0e1210ae856badea9b1a80ffbd095fcbd2a3bc9e9e7b94eef8094f670eeb17c26f143e450b986620fdf250bbe74b90772f30ebfa24fdd
MISC metadata.xml 515 BLAKE2B d300be91135a6a7dcc55a61b484b5dd1785663b9f3b51d621dcacffd9ec5747b69bb227f60dce1bf30a57fe93629de3c82fa7138a5f056e4f349ce6909453020 SHA512 af8e2bbded13ef475d1577eb4faa27e17a045804f1de3e79c4c3d736871db304872fc65db0d606c243292392fb4ac773711ad9e153369714689138249d469158
diff --git a/dev-libs/apr-util/apr-util-1.6.1-r1.ebuild b/dev-libs/apr-util/apr-util-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..55ba63acefc3
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-1.6.1-r1.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Usually apr-util has the same PV as apr, but in case of security fixes, this may change.
+# APR_PV="${PV}"
+APR_PV="1.6.2"
+
+inherit autotools db-use eutils libtool multilib toolchain-funcs
+
+DESCRIPTION="Apache Portable Runtime Utility Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="berkdb doc gdbm ldap libressl mysql nss odbc openssl postgres sqlite static-libs"
+#RESTRICT="test"
+
+RDEPEND="
+ dev-libs/expat
+ >=dev-libs/apr-${APR_PV}:1=
+ berkdb? ( >=sys-libs/db-4:= )
+ gdbm? ( sys-libs/gdbm:= )
+ ldap? ( =net-nds/openldap-2* )
+ mysql? ( =virtual/mysql-5* )
+ nss? ( dev-libs/nss )
+ odbc? ( dev-db/unixODBC )
+ openssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+ postgres? ( dev-db/postgresql:= )
+ sqlite? ( dev-db/sqlite:3 )
+"
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/libtool-2.4.2
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=(CHANGES NOTICE README)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.3-sysroot.patch #385775
+)
+
+src_prepare() {
+ default
+
+ # Fix usage of libmysqlclient (bug #620230)
+ grep -lrF "libmysqlclient_r" "${S}" \
+ | xargs sed 's@libmysqlclient_r@libmysqlclient@g' -i \
+ || die
+
+ mv configure.{in,ac} || die
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ local myconf=(
+ --datadir="${EPREFIX}"/usr/share/apr-util-1
+ --with-apr="${SYSROOT}${EPREFIX}"/usr
+ --with-expat="${EPREFIX}"/usr
+ --without-sqlite2
+ $(use_with gdbm)
+ $(use_with ldap)
+ $(use_with mysql)
+ $(use_with nss)
+ $(use_with odbc)
+ $(use_with openssl)
+ $(use_with postgres pgsql)
+ $(use_with sqlite sqlite3)
+ )
+
+ tc-is-static-only && myconf+=( --disable-util-dso )
+
+ if use berkdb; then
+ local db_version
+ db_version="$(db_findver sys-libs/db)" || die "Unable to find Berkeley DB version"
+ db_version="$(db_ver_to_slot "${db_version}")"
+ db_version="${db_version/\./}"
+ myconf+=(
+ --with-dbm=db${db_version}
+ # We use $T for the libdir because otherwise it'd simply be the normal
+ # system libdir. That's pointless as the compiler will search it for
+ # us already. This makes cross-compiling and such easier.
+ --with-berkeley-db="${SYSROOT}$(db_includedir 2>/dev/null):${T}"
+ )
+ else
+ myconf+=( --without-berkeley-db )
+ fi
+
+ if use nss || use openssl ; then
+ myconf+=( --with-crypto ) # 518708
+ fi
+
+ econf "${myconf[@]}"
+ # Use the current env build settings rather than whatever apr was built with.
+ sed -i -r \
+ -e "/^(apr_builddir|apr_builders|top_builddir)=/s:=:=${SYSROOT}:" \
+ -e "/^CC=/s:=.*:=$(tc-getCC):" \
+ -e '/^(C|CPP|CXX|LD)FLAGS=/d' \
+ -e '/^LTFLAGS/s:--silent::' \
+ build/rules.mk || die
+}
+
+src_compile() {
+ emake
+ use doc && emake dox
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name "*.la" -delete || die
+ if [[ -d "${ED%/}/usr/$(get_libdir)/apr-util-${SLOT}" ]] ; then
+ find "${ED%/}/usr/$(get_libdir)/apr-util-${SLOT}" -name "*.a" -delete || die
+ fi
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -not -name "*$(get_libname)" -delete || die
+ fi
+
+ if use doc ; then
+ docinto html
+ dodoc -r docs/dox/html/*
+ fi
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ rm "${ED%/}/usr/$(get_libdir)/aprutil.exp" || die
+}