summaryrefslogtreecommitdiff
path: root/dev-libs/apr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
commit171a011ad3a131671aeb5a98b9e3adf219ad2865 (patch)
tree0c877a3d1a37f10e37ad7168cfc52054aa0948a7 /dev-libs/apr
parent75fc75ae1f0481ffdb78450e801a9b443ba641bd (diff)
gentoo resync : 02.04.2018
Diffstat (limited to 'dev-libs/apr')
-rw-r--r--dev-libs/apr/Manifest1
-rw-r--r--dev-libs/apr/apr-1.6.3-r1.ebuild147
2 files changed, 148 insertions, 0 deletions
diff --git a/dev-libs/apr/Manifest b/dev-libs/apr/Manifest
index 818a1706c2ce..e60296adf0fa 100644
--- a/dev-libs/apr/Manifest
+++ b/dev-libs/apr/Manifest
@@ -8,5 +8,6 @@ DIST apr-1.6.2.tar.bz2 853363 BLAKE2B 99ff559a5a974c1cd116dbaa65a03c731ed8cdb439
DIST apr-1.6.3.tar.bz2 854100 BLAKE2B ac3d38ef201d92bb2e50a35b6f41de6120e6196f1412377eae56f013dfebbe7fe8461fcd4e5e82be275bde51253a7f1c5f708e780203382b64fe61637d97226c SHA512 f6b8679ae7fafff793c825c78775c84a646267c441710a50664589850e13148719b4eab48ab6e7c95b7aed085cff831115687434a7b160dcc2faa0eae63ac996
EBUILD apr-1.5.2.ebuild 4088 BLAKE2B 42d181fe7480bffff9577aff115731ac62e70513ee49fe459db6d82ac62431ac2323c698d139285449defe377c7fd90c586342773fb05722003cd4075807f165 SHA512 1675f275f3c37a3141f73434ec17ba6841f153c6a12edc20997f9cf5da462126cdc77d5ff7a625b0a3c9ef8e08480163c6b004ccd374d8e96f6a2a19df1fc775
EBUILD apr-1.6.2.ebuild 4079 BLAKE2B 0760c6a464e2ba6006a815d335aeb37a8319b6513252d113c65713417cbad361a892d1da65d63eeff7341881724f5790273b326116927e1c70acac8aa054c0e0 SHA512 b0d0cd2ae97fb8d3622d891385f17a2b2098b55278563880d4062f0014ea1831478cbd9363c898431a3073d7340332c3406e55c08eb075752865b021b63d29c6
+EBUILD apr-1.6.3-r1.ebuild 4125 BLAKE2B 554bcdbfb44ade141ca48850d4c62bda067feb802b03f38d1a8b6d46a8f20fed1cf9e3498c54dee16e18bee1ad62df6687ef4839b1c6f5f92fea783a6d2b63a9 SHA512 8b53c6e0b587f63b75cd31099fdadeb4e410a1d825dd681ad0e3f9553a58c02dd1eb3dca47cacd580a925a46e9273c294d1e40f6a5b748d420b38f3e19e53fda
EBUILD apr-1.6.3.ebuild 4079 BLAKE2B 0760c6a464e2ba6006a815d335aeb37a8319b6513252d113c65713417cbad361a892d1da65d63eeff7341881724f5790273b326116927e1c70acac8aa054c0e0 SHA512 b0d0cd2ae97fb8d3622d891385f17a2b2098b55278563880d4062f0014ea1831478cbd9363c898431a3073d7340332c3406e55c08eb075752865b021b63d29c6
MISC metadata.xml 433 BLAKE2B 5c4d90e1cdc1424b0be48c81e249e5c3fa6740998cc37c52a164c25238bc7c20ca6a2c4a4924ccd076aaaa74c7655d95d5526a3d110fc0a10b931d9c41de4060 SHA512 7a1b6a73160b108816332f90e4e540f555e748584925ac3c7bb303ce5b6328abf255fc3f1c2b0e13f3c5d763841e847e400e781764083e3e96bc3809871a0df6
diff --git a/dev-libs/apr/apr-1.6.3-r1.ebuild b/dev-libs/apr/apr-1.6.3-r1.ebuild
new file mode 100644
index 000000000000..ba7eb74e48bf
--- /dev/null
+++ b/dev-libs/apr/apr-1.6.3-r1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools libtool ltprune multilib toolchain-funcs
+
+DESCRIPTION="Apache Portable Runtime Library"
+HOMEPAGE="https://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="1/${PV%.*}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc elibc_FreeBSD older-kernels-compatibility selinux static-libs +urandom"
+
+CDEPEND="elibc_glibc? ( >=sys-apps/util-linux-2.16 )
+ elibc_mintlib? ( >=sys-apps/util-linux-2.18 )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-apache )"
+DEPEND="${CDEPEND}
+ >=sys-devel/libtool-2.4.2
+ doc? ( app-doc/doxygen )"
+
+DOCS=( CHANGES NOTICE README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-mint.patch
+ "${FILESDIR}"/${PN}-1.5.0-libtool.patch
+ "${FILESDIR}"/${PN}-1.5.0-cross-types.patch
+ "${FILESDIR}"/${PN}-1.5.0-sysroot.patch #385775
+)
+
+src_prepare() {
+ default
+
+ mv configure.in configure.ac || die
+ AT_M4DIR="build" eautoreconf
+ elibtoolize
+
+ eapply "${FILESDIR}/config.layout.patch"
+}
+
+src_configure() {
+ local myconf=(
+ --enable-layout=gentoo
+ --enable-nonportable-atomics
+ --enable-posix-shm
+ --enable-threads
+ $(use_enable static-libs static)
+ )
+
+ [[ ${CHOST} == *-mint* ]] && export ac_cv_func_poll=no
+
+ if use older-kernels-compatibility; then
+ local apr_cv_accept4 apr_cv_dup3 apr_cv_epoll_create1 apr_cv_sock_cloexec
+ export apr_cv_accept4="no"
+ export apr_cv_dup3="no"
+ export apr_cv_epoll_create1="no"
+ export apr_cv_sock_cloexec="no"
+ fi
+ if tc-is-cross-compiler; then
+ # The apache project relies heavily on AC_TRY_RUN and doesn't
+ # have any sane cross-compiling fallback logic.
+ export \
+ ac_cv_file__dev_zero="yes" \
+ ac_cv_func_sem_open="yes" \
+ ac_cv_negative_eai="yes" \
+ ac_cv_o_nonblock_inherited="no" \
+ ac_cv_struct_rlimit="yes" \
+ ap_cv_atomic_builtins="yes" \
+ apr_cv_accept4="yes" \
+ apr_cv_dup3="yes" \
+ apr_cv_epoll="yes" \
+ apr_cv_epoll_create1="yes" \
+ apr_cv_gai_addrconfig="yes" \
+ apr_cv_mutex_recursive="yes" \
+ apr_cv_mutex_robust_shared="yes" \
+ apr_cv_process_shared_works="yes" \
+ apr_cv_pthreads_lib="-pthread" \
+ apr_cv_sock_cloexec="yes" \
+ apr_cv_tcp_nodelay_with_cork="yes"
+ fi
+
+ if use urandom; then
+ myconf+=( --with-devrandom=/dev/urandom )
+ elif (( ${CHOST#*-hpux11.} <= 11 )); then
+ : # no /dev/*random on hpux11.11 and before, $PN detects this.
+ else
+ myconf+=( --with-devrandom=/dev/random )
+ fi
+
+ tc-is-static-only && myconf+=( --disable-dso )
+
+ # shl_load does not search runpath, but hpux11 supports dlopen
+ [[ ${CHOST} == *-hpux11* ]] && myconf+=( --enable-dso=dlfcn )
+
+ if [[ ${CHOST} == *-solaris2.10 ]]; then
+ case $(<$([[ ${CHOST} != ${CBUILD} ]] && echo "${EPREFIX}/usr/${CHOST}")/usr/include/atomic.h) in
+ *atomic_cas_ptr*) ;;
+ *)
+ elog "You do not have Solaris Patch ID "$(
+ [[ ${CHOST} == sparc* ]] && echo 118884 || echo 118885
+ )" (Problem 4954703) installed on your host ($(hostname)),"
+ elog "using generic atomic operations instead."
+ myconf+=( --disable-nonportable-atomics )
+ ;;
+ esac
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ if tc-is-cross-compiler; then
+ # This header is the same across targets, so use the build compiler.
+ emake tools/gen_test_char
+ tc-export_build_env BUILD_CC
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} \
+ tools/gen_test_char.c -o tools/gen_test_char || die
+ fi
+
+ emake
+
+ if use doc; then
+ emake dox
+ fi
+}
+
+src_install() {
+ default
+
+ # Prallel install breaks since apr-1.5.1
+ #make -j1 DESTDIR="${D}" install || die
+
+ prune_libtool_files --all
+
+ if use doc; then
+ docinto html
+ dodoc -r docs/dox/html/*
+ fi
+
+ # This file is only used on AIX systems, which Gentoo is not,
+ # and causes collisions between the SLOTs, so remove it.
+ # Even in Prefix, we don't need this on AIX.
+ rm -f "${ED%/}/usr/$(get_libdir)/apr.exp"
+}