summaryrefslogtreecommitdiff
path: root/dev-libs/atf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /dev-libs/atf
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'dev-libs/atf')
-rw-r--r--dev-libs/atf/Manifest2
-rw-r--r--dev-libs/atf/atf-0.21-r1.ebuild24
-rw-r--r--dev-libs/atf/files/atf-0.21-getopt-solaris.patch12
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/atf/Manifest b/dev-libs/atf/Manifest
index 43cfcef92d02..fdc9d0f93732 100644
--- a/dev-libs/atf/Manifest
+++ b/dev-libs/atf/Manifest
@@ -1,3 +1,5 @@
+AUX atf-0.21-getopt-solaris.patch 191 BLAKE2B 100e710c5cd10d5b0cd35fc2b6fcbba440496c3bdf99b7b88162b214e1fbf030cf54a0289b801b9946f89df0fe26ecc452f498ecd9e546462ccfd989aa313f64 SHA512 c98c062793abb014731e249d833e94fb4c0e7f5ced37f7310caa6e3a26a3b391c4fe90133656c21f6bb467af5d8039f887a3a42630b6e9725ecb84b99309a94b
DIST atf-0.21.tar.gz 567791 BLAKE2B e9449bb61008a91c10050462e84ff65c6fd88124db56ff3f6c149ff47fe8647fe8fe786cd7b1106cbfd62723a57ab613432323f266a93a4c86d8a6ab39bfcc0a SHA512 9b4b67d7d0d1f65cc9571d38c67dfc620b08ff7c0abf57d87bcae54055b4af21f95f3363f2cf8ee9b13b89a5351bc58669b784a0fd8c1beb0664c14933c10ce1
+EBUILD atf-0.21-r1.ebuild 640 BLAKE2B 706df2739402cc239334a82f6e6e3ca3341709be287c064c13fff689511c4005e13d35e2b855ae72667ce87ed69338564dc18a9c8e05bddbd40c64e581077ce1 SHA512 4f33193da9f1f5fbb22e1492581fff63a02dc3d92554345a0b89316a08802728b95f77e759665676cfe45dd158dbdeb56391ed12e504d3466f05e2e3ffc7b6f1
EBUILD atf-0.21.ebuild 489 BLAKE2B e74c5ca6fbd9fc2bee96632d5dcbda578c1c363b64dfffbf8a52903c787f54e9854e7ba786a2a5b8f12f859db945ca0047eccedfe03e191924f7dbce03e9be11 SHA512 63027784fb4ed54582ba81c7c88ded888a5f125d3e768a5c0b6958d76971ad2083e6865feb6dae99fb9bbfd06fc4577da67a86f8228feef49e4c5c9415ddd958
MISC metadata.xml 246 BLAKE2B f94a229d0ffd7220f14c23ca2b0b6b84128338b5af27cd18ddb0c9e2f95f51c943fdfbc368c03b4a87d7bb381c668158fdc169fd067cc0cd8cd35852acc29d62 SHA512 b6df287a6e1f18bf267a05d8eb6dea788ae7ec74de31d9cea76fea038e4090c6a83d62221505d280d55e9b314d059c409e442951d78eb3a58928307ff118147b
diff --git a/dev-libs/atf/atf-0.21-r1.ebuild b/dev-libs/atf/atf-0.21-r1.ebuild
new file mode 100644
index 000000000000..8f0c520fae81
--- /dev/null
+++ b/dev-libs/atf/atf-0.21-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune
+
+DESCRIPTION="Libraries to write tests in C, C++ and shell"
+HOMEPAGE="https://github.com/jmmv/atf"
+SRC_URI="https://github.com/jmmv/atf/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="virtual/pkgconfig"
+
+PATCHES=( ${FILESDIR}/${P}-getopt-solaris.patch )
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-libs/atf/files/atf-0.21-getopt-solaris.patch b/dev-libs/atf/files/atf-0.21-getopt-solaris.patch
new file mode 100644
index 000000000000..d70af36ce40e
--- /dev/null
+++ b/dev-libs/atf/files/atf-0.21-getopt-solaris.patch
@@ -0,0 +1,12 @@
+On Solaris, getopt(3) is in stdio.h.
+
+--- a/atf-c/tp_test.c
++++ b/atf-c/tp_test.c
+@@ -25,6 +25,7 @@
+
+ #include "atf-c/tp.h"
+
++#include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
+