summaryrefslogtreecommitdiff
path: root/dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild')
-rw-r--r--dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild b/dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild
index a0d6bce25cf4..aaf6a73ee9aa 100644
--- a/dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild
+++ b/dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="Cross-Platform HW accelerated CRC32c and CRC32 with software fallbacks"
HOMEPAGE="https://github.com/awslabs/aws-checksums"
@@ -12,13 +12,13 @@ SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
IUSE="test"
+
RESTRICT="!test? ( test )"
src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}